Autodesk.Interop.ConnectionPoint Namespace

[image]

Autodesk Connection Point
Autodesk.Interop.ConnectionPoint Namespace
Send Feedback
Autodesk Connection Point (C) Copyright 2010 by Autodesk, Inc.

Classes

 | Class | Description
Public class | ConnectionPointManager | This class is used to manage the connection point block table record, connect and disconnect connection points, and provide some useful connection point services.
Public class | ConnectionPointReferenceUtil | This class is used to work with a connection point. A connection point is a block reference that uses "ADSK_CONNECTION_POINT" as it's block definition and has necessary XDATA needed to drive functionality.


ConnectionPointManager Class

[image]

Autodesk Connection Point
ConnectionPointManager Class
Members See Also Send Feedback
This class is used to manage the connection point block table record, connect and disconnect connection points, and provide some useful connection point services.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConnectionPointManager
Visual Basic
Public Class ConnectionPointManager
Visual C++
public ref class ConnectionPointManager

Inheritance Hierarchy

System..::..Object
Autodesk.Interop.ConnectionPoint..::..ConnectionPointManager

See Also

ConnectionPointManager Members
Autodesk.Interop.ConnectionPoint Namespace
Autodesk.Interop.ConnectionPoint..::..ConnectionPointReferenceUtil


ConnectionPointManager Members

[image] [image]

Autodesk Connection Point
ConnectionPointManager Members
ConnectionPointManager Class Constructors Methods Properties See Also Send Feedback

The ConnectionPointManager type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionPointManager | Initializes a new instance of the ConnectionPointManager class

Methods

 | Name | Description
 | Connect(BlockReference, BlockReference) | This method connects two connection points to each other.
 | Connect(ObjectId, ObjectId) | This method connects two connection points to each other.
 | Connect(Transaction, ObjectId, ObjectId) | This method connects two connection points to each other.
 | CreateBlockReference | This method creates a new connection point and appends it to the block table record provided.
 | CreateBlockTableRecord(Database) | This method is used to create the ACP block table record.
 | CreateBlockTableRecord(Transaction, Database) | This method is used to create the connection point block table record and register XDATA RegApp named ADSK_CONNECTION_POINT.
 | Disconnect(BlockReference) | This method disconnects a connection point.
 | Disconnect(ObjectId) | This method disconnects a connection point.
 | Disconnect(Transaction, ObjectId) | This method disconnects a connection point.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetBlockTableRecordId(Database) | This method is used to acquire the ObjectId of the ACP block table record.
 | GetBlockTableRecordId(Transaction, Database) | This method is used to acquire the ObjectId of the ACP block table record.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | IsBlockTableRecordDefined | This method is used to determine if the ACP block table record is defined.
 | IsConnectionPoint | This method is used to check whether a block reference is a connection point.
 | LoadProperties | This method loads the attributes and values (if applicable) from an XML file.
Protected method | MemberwiseClone | (Inherited from Object.)
 | SaveProperties | This method saves the properties to an XML file.
Public method | ToString | (Inherited from Object.)

Properties

Name | Description
BlockName | This property is used to get the block definition name for ACP objects.
FileName | This property is used to get the prefix of XML files.

See Also

ConnectionPointManager Class
Autodesk.Interop.ConnectionPoint Namespace


ConnectionPointManager Constructor

[image]

Autodesk Connection Point
ConnectionPointManager Constructor
ConnectionPointManager Class See Also Send Feedback
Initializes a new instance of the ConnectionPointManager class

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnectionPointManager()
Visual Basic
Public Sub New
Visual C++
public:
ConnectionPointManager()

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager Methods

[image] [image]

Autodesk Connection Point
ConnectionPointManager Methods
ConnectionPointManager Class See Also Send Feedback

The ConnectionPointManager type exposes the following members.

Methods

 | Name | Description
 | Connect(BlockReference, BlockReference) | This method connects two connection points to each other.
 | Connect(ObjectId, ObjectId) | This method connects two connection points to each other.
 | Connect(Transaction, ObjectId, ObjectId) | This method connects two connection points to each other.
 | CreateBlockReference | This method creates a new connection point and appends it to the block table record provided.
 | CreateBlockTableRecord(Database) | This method is used to create the ACP block table record.
 | CreateBlockTableRecord(Transaction, Database) | This method is used to create the connection point block table record and register XDATA RegApp named ADSK_CONNECTION_POINT.
 | Disconnect(BlockReference) | This method disconnects a connection point.
 | Disconnect(ObjectId) | This method disconnects a connection point.
 | Disconnect(Transaction, ObjectId) | This method disconnects a connection point.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
 | GetBlockTableRecordId(Database) | This method is used to acquire the ObjectId of the ACP block table record.
 | GetBlockTableRecordId(Transaction, Database) | This method is used to acquire the ObjectId of the ACP block table record.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | IsBlockTableRecordDefined | This method is used to determine if the ACP block table record is defined.
 | IsConnectionPoint | This method is used to check whether a block reference is a connection point.
 | LoadProperties | This method loads the attributes and values (if applicable) from an XML file.
Protected method | MemberwiseClone | (Inherited from Object.)
 | SaveProperties | This method saves the properties to an XML file.
Public method | ToString | (Inherited from Object.)

See Also

ConnectionPointManager Class


ConnectionPointManager.Connect Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
Connect(BlockReference, BlockReference) | This method connects two connection points to each other.
Connect(ObjectId, ObjectId) | This method connects two connection points to each other.
Connect(Transaction, ObjectId, ObjectId) | This method connects two connection points to each other.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.Connect Method (BlockReference, BlockReference)

[image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method (BlockReference, BlockReference)
ConnectionPointManager Class See Also Send Feedback
This method connects two connection points to each other.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Connect(
    BlockReference br1,
    BlockReference br2
)
Visual Basic
Public Shared Sub Connect (
    br1 As BlockReference,
    br2 As BlockReference
)
Visual C++
public:
static void Connect(
    BlockReference^ br1,
    BlockReference^ br2
)

Parameters

br1
Type: BlockReference
Input block reference opened for write as target.
br2
Type: BlockReference
Input block reference opened for read as source.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method modifies br1's XDATA using the GUID found in br2's XDATA. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
Connect Overload


ConnectionPointManager.Connect Method (ObjectId, ObjectId)

[image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method (ObjectId, ObjectId)
ConnectionPointManager Class See Also Send Feedback
This method connects two connection points to each other.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Connect(
    ObjectId brId1,
    ObjectId brId2
)
Visual Basic
Public Shared Sub Connect (
    brId1 As ObjectId,
    brId2 As ObjectId
)
Visual C++
public:
static void Connect(
    ObjectId brId1,
    ObjectId brId2
)

Parameters

brId1
Type: ObjectId
Input block reference id to open for write as target.
brId2
Type: ObjectId
Input block reference id to open for read as source.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method creates a transaction using the database of brId1 and modifies brId1's XDATA using the GUID found in brId2's XDATA. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
Connect Overload


ConnectionPointManager.Connect Method (Transaction, ObjectId, ObjectId)

[image]

Autodesk Connection Point
ConnectionPointManager..::..Connect Method (Transaction, ObjectId, ObjectId)
ConnectionPointManager Class See Also Send Feedback
This method connects two connection points to each other.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Connect(
    Transaction tr,
    ObjectId brId1,
    ObjectId brId2
)
Visual Basic
Public Shared Sub Connect (
    tr As Transaction,
    brId1 As ObjectId,
    brId2 As ObjectId
)
Visual C++
public:
static void Connect(
    Transaction^ tr,
    ObjectId brId1,
    ObjectId brId2
)

Parameters

tr
Type: Transaction
Input the transaction to use.
brId1
Type: ObjectId
Input block reference id to open for write as target.
brId2
Type: ObjectId
Input block reference id to open for read as source.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method modifies brId1's XDATA using the GUID found in brId2's XDATA. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
Connect Overload


ConnectionPointManager.CreateBlockReference Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockReference Method
ConnectionPointManager Class See Also Send Feedback
This method creates a new connection point and appends it to the block table record provided.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static BlockReference CreateBlockReference(
    Transaction tr,
    BlockTableRecord btr
)
Visual Basic
Public Shared Function CreateBlockReference (
    tr As Transaction,
    btr As BlockTableRecord
) As BlockReference
Visual C++
public:
static BlockReference^ CreateBlockReference(
    Transaction^ tr,
    BlockTableRecord^ btr
)

Parameters

tr
Type: Transaction
Input the transaction to use.
btr
Type: BlockTableRecord
Input the block table record that will be the owner.

Return Value

Type: BlockReference
The newly created block reference instance.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.CreateBlockTableRecord Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockTableRecord Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
CreateBlockTableRecord(Database) | This method is used to create the ACP block table record.
CreateBlockTableRecord(Transaction, Database) | This method is used to create the connection point block table record and register XDATA RegApp named ADSK_CONNECTION_POINT.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.CreateBlockTableRecord Method (Database)

[image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockTableRecord Method (Database)
ConnectionPointManager Class See Also Send Feedback
This method is used to create the ACP block table record.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ObjectId CreateBlockTableRecord(
    Database dwg
)
Visual Basic
Public Shared Function CreateBlockTableRecord (
    dwg As Database
) As ObjectId
Visual C++
public:
static ObjectId CreateBlockTableRecord(
    Database^ dwg
)

Parameters

dwg
Type: Database
Input drawing database where the ACP block table record is to be created.

Return Value

Type: ObjectId
ObjectId of the ACP block table record.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method starts a transaction to open up the block table in write mode then creates a new block table record named "ADSK_CONNECTION_POINT". Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
CreateBlockTableRecord Overload


ConnectionPointManager.CreateBlockTableRecord Method (Transaction, Database)

[image]

Autodesk Connection Point
ConnectionPointManager..::..CreateBlockTableRecord Method (Transaction, Database)
ConnectionPointManager Class See Also Send Feedback
This method is used to create the connection point block table record and register XDATA RegApp named ADSK_CONNECTION_POINT.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ObjectId CreateBlockTableRecord(
    Transaction tr,
    Database dwg
)
Visual Basic
Public Shared Function CreateBlockTableRecord (
    tr As Transaction,
    dwg As Database
) As ObjectId
Visual C++
public:
static ObjectId CreateBlockTableRecord(
    Transaction^ tr,
    Database^ dwg
)

Parameters

tr
Type: Transaction
Input the externally managed transaction to use.
dwg
Type: Database
Input drawing database where the ACP block table record is to be created.

Return Value

Type: ObjectId
ObjectId of the ACP block table record.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method opens up the block and regapp tables in write mode using the transaction passed in to create a new record in each named "ADSK_CONNECTION_POINT". Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
CreateBlockTableRecord Overload


ConnectionPointManager.Disconnect Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
Disconnect(BlockReference) | This method disconnects a connection point.
Disconnect(ObjectId) | This method disconnects a connection point.
Disconnect(Transaction, ObjectId) | This method disconnects a connection point.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.Disconnect Method (BlockReference)

[image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method (BlockReference)
ConnectionPointManager Class See Also Send Feedback
This method disconnects a connection point.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Disconnect(
    BlockReference br
)
Visual Basic
Public Shared Sub Disconnect (
    br As BlockReference
)
Visual C++
public:
static void Disconnect(
    BlockReference^ br
)

Parameters

br
Type: BlockReference
Input block reference opened for write.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method modifies br's XDATA by assigning a new GUID. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
Disconnect Overload


ConnectionPointManager.Disconnect Method (ObjectId)

[image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method (ObjectId)
ConnectionPointManager Class See Also Send Feedback
This method disconnects a connection point.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Disconnect(
    ObjectId brId
)
Visual Basic
Public Shared Sub Disconnect (
    brId As ObjectId
)
Visual C++
public:
static void Disconnect(
    ObjectId brId
)

Parameters

brId
Type: ObjectId
Input block reference id to open for write.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method starts a transaction in br's database and modifies br's XDATA by assigning a new GUID. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
Disconnect Overload


ConnectionPointManager.Disconnect Method (Transaction, ObjectId)

[image]

Autodesk Connection Point
ConnectionPointManager..::..Disconnect Method (Transaction, ObjectId)
ConnectionPointManager Class See Also Send Feedback
This method disconnects a connection point.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Disconnect(
    Transaction tr,
    ObjectId brId
)
Visual Basic
Public Shared Sub Disconnect (
    tr As Transaction,
    brId As ObjectId
)
Visual C++
public:
static void Disconnect(
    Transaction^ tr,
    ObjectId brId
)

Parameters

tr
Type: Transaction
Input transaction to use.
brId
Type: ObjectId
Input block reference id to open for write.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method modifies br's XDATA by assigning a new GUID. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
Disconnect Overload


ConnectionPointManager.GetBlockTableRecordId Method

[image] [image]

Autodesk Connection Point
ConnectionPointManager..::..GetBlockTableRecordId Method
ConnectionPointManager Class See Also Send Feedback

Overload List

Name | Description
GetBlockTableRecordId(Database) | This method is used to acquire the ObjectId of the ACP block table record.
GetBlockTableRecordId(Transaction, Database) | This method is used to acquire the ObjectId of the ACP block table record.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.GetBlockTableRecordId Method (Database)

[image]

Autodesk Connection Point
ConnectionPointManager..::..GetBlockTableRecordId Method (Database)
ConnectionPointManager Class See Also Send Feedback
This method is used to acquire the ObjectId of the ACP block table record.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ObjectId GetBlockTableRecordId(
    Database dwg
)
Visual Basic
Public Shared Function GetBlockTableRecordId (
    dwg As Database
) As ObjectId
Visual C++
public:
static ObjectId GetBlockTableRecordId(
    Database^ dwg
)

Parameters

dwg
Type: Database
Input drawing database to check.

Return Value

Type: ObjectId
ObjectId of the ACP block table record; it can be ObjectId.Null.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method starts a transaction then opens up the block table in read mode to acquire the block table record id of "ADSK_CONNECTION_POINT". Call this method within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
GetBlockTableRecordId Overload


ConnectionPointManager.GetBlockTableRecordId Method (Transaction, Database)

[image]

Autodesk Connection Point
ConnectionPointManager..::..GetBlockTableRecordId Method (Transaction, Database)
ConnectionPointManager Class See Also Send Feedback
This method is used to acquire the ObjectId of the ACP block table record.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ObjectId GetBlockTableRecordId(
    Transaction tr,
    Database dwg
)
Visual Basic
Public Shared Function GetBlockTableRecordId (
    tr As Transaction,
    dwg As Database
) As ObjectId
Visual C++
public:
static ObjectId GetBlockTableRecordId(
    Transaction^ tr,
    Database^ dwg
)

Parameters

tr
Type: Transaction
Input transaction to use.
dwg
Type: Database
Input drawing database to check.

Return Value

Type: ObjectId
ObjectId of the ACP block table record; it can be ObjectId.Null.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method opens up the block table in read mode to acquire the block table record id of "ADSK_CONNECTION_POINT". Call this method within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
GetBlockTableRecordId Overload


ConnectionPointManager.IsBlockTableRecordDefined Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..IsBlockTableRecordDefined Method
ConnectionPointManager Class See Also Send Feedback
This method is used to determine if the ACP block table record is defined.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool IsBlockTableRecordDefined(
    Database dwg
)
Visual Basic
Public Shared Function IsBlockTableRecordDefined (
    dwg As Database
) As Boolean
Visual C++
public:
static bool IsBlockTableRecordDefined(
    Database^ dwg
)

Parameters

dwg
Type: Database
Input drawing database to check.

Return Value

Type: Boolean
True if the ACP block table record is found, otherwise false.

See Also

ConnectionPointManager Class
ConnectionPointManager Members
Autodesk.Interop.ConnectionPoint Namespace
ConnectionPointManager..::..GetBlockTableRecordId(Database)


ConnectionPointManager.IsConnectionPoint Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..IsConnectionPoint Method
ConnectionPointManager Class See Also Send Feedback
This method is used to check whether a block reference is a connection point.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool IsConnectionPoint(
    BlockReference blkRef
)
Visual Basic
Public Shared Function IsConnectionPoint (
    blkRef As BlockReference
) As Boolean
Visual C++
public:
static bool IsConnectionPoint(
    BlockReference^ blkRef
)

Parameters

blkRef
Type: BlockReference
Input the block reference to check.

Return Value

Type: Boolean
True if the block reference is a connection point; otherwise false.

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.LoadProperties Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..LoadProperties Method
ConnectionPointManager Class See Also Send Feedback
This method loads the attributes and values (if applicable) from an XML file.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Dictionary<string, string> LoadProperties(
    string strXmlFileName
)
Visual Basic
Public Shared Function LoadProperties (
    strXmlFileName As String
) As Dictionary(Of String, String)
Visual C++
public:
static Dictionary<String^, String^>^ LoadProperties(
    String^ strXmlFileName
)

Parameters

strXmlFileName
Type: System..::..String
File name to load.

Return Value

Type: Dictionary <(Of <(<' String, String >)>)>
Dictionary of property name/value pairs.

Remarks

This method does not catch exceptions as it attempts to read in the specified XML file. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.SaveProperties Method

[image]

Autodesk Connection Point
ConnectionPointManager..::..SaveProperties Method
ConnectionPointManager Class See Also Send Feedback
This method saves the properties to an XML file.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SaveProperties(
    string strXmlFileName,
    Dictionary<string, string> props
)
Visual Basic
Public Shared Sub SaveProperties (
    strXmlFileName As String,
    props As Dictionary(Of String, String)
)
Visual C++
public:
static void SaveProperties(
    String^ strXmlFileName,
    Dictionary<String^, String^>^ props
)

Parameters

strXmlFileName
Type: System..::..String
Input file name to save to.
props
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Input dictionary with property name/value pairs.

Remarks

This method does not catch exceptions as it attempts to save to the specified XML file. If the file exists, it is overwritten. Call this function within a try / catch block.

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager Properties

[image] [image]

Autodesk Connection Point
ConnectionPointManager Properties
ConnectionPointManager Class See Also Send Feedback

The ConnectionPointManager type exposes the following members.

Properties

Name | Description
BlockName | This property is used to get the block definition name for ACP objects.
FileName | This property is used to get the prefix of XML files.

See Also

ConnectionPointManager Class


ConnectionPointManager.BlockName Property

[image]

Autodesk Connection Point
ConnectionPointManager..::..BlockName Property
ConnectionPointManager Class See Also Send Feedback
This property is used to get the block definition name for ACP objects.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string BlockName { get; }
Visual Basic
Public Shared ReadOnly Property BlockName As String
    Get
Visual C++
public:
static property String^ BlockName {
    String^ get ();
}

Property Value

Type: String

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointManager.FileName Property

[image]

Autodesk Connection Point
ConnectionPointManager..::..FileName Property
ConnectionPointManager Class See Also Send Feedback
This property is used to get the prefix of XML files.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string FileName { get; }
Visual Basic
Public Shared ReadOnly Property FileName As String
    Get
Visual C++
public:
static property String^ FileName {
    String^ get ();
}

Property Value

Type: String

See Also

ConnectionPointManager Class
ConnectionPointManager Members


ConnectionPointReferenceUtil Class

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil Class
Members See Also Send Feedback
This class is used to work with a connection point. A connection point is a block reference that uses "ADSK_CONNECTION_POINT" as it's block definition and has necessary XDATA needed to drive functionality.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConnectionPointReferenceUtil
Visual Basic
Public Class ConnectionPointReferenceUtil
Visual C++
public ref class ConnectionPointReferenceUtil

Inheritance Hierarchy

System..::..Object
Autodesk.Interop.ConnectionPoint..::..ConnectionPointReferenceUtil

See Also

ConnectionPointReferenceUtil Members
Autodesk.Interop.ConnectionPoint Namespace
Autodesk.Interop.ConnectionPoint..::..ConnectionPointManager


ConnectionPointReferenceUtil Members

[image] [image]

Autodesk Connection Point
ConnectionPointReferenceUtil Members
ConnectionPointReferenceUtil Class Constructors Methods Properties See Also Send Feedback

The ConnectionPointReferenceUtil type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionPointReferenceUtil | Constructor

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetProperties | This method returns all the properties stored in XDATA for the RegAppName of ADSK_CONNECTION_POINT.
Public method | GetProperty | This method returns a specific property value.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SaveToXml | This method save to XML all the connection point properties.
Public method | SetProperties | This method saves all the property name / value pairs to the connection point's XDATA.
Public method | SetProperty | This method assigns property name and value pair.
Public method | ToString | (Inherited from Object.)

Properties

 | Name | Description
Public property | AttachedTo | This property gets or sets the entity the connection point is attached to.
Public property | BlockReference | This property provides the block reference that represents the connection point.
Public property | Direction | This property is a helper to quickly get or set the block reference's direction.
Public property | Guid | This property gets or sets the connection point's unique identifier.
Public property | IsValid | This property inspects the block reference to see if it is a valid connection point.
Public property | Name | This property returns the block reference's block name.
Public property | Position | This property is a helper to quickly get or set the block reference's position.

See Also

ConnectionPointReferenceUtil Class


ConnectionPointReferenceUtil Constructor

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil Constructor
ConnectionPointReferenceUtil Class See Also Send Feedback
Constructor

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConnectionPointReferenceUtil(
    BlockReference blkRef
)
Visual Basic
Public Sub New (
    blkRef As BlockReference
)
Visual C++
public:
ConnectionPointReferenceUtil(
    BlockReference^ blkRef
)

Parameters

blkRef
Type: BlockReference
Connection point block reference to use.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil Methods

[image] [image]

Autodesk Connection Point
ConnectionPointReferenceUtil Methods
ConnectionPointReferenceUtil Class See Also Send Feedback

The ConnectionPointReferenceUtil type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetProperties | This method returns all the properties stored in XDATA for the RegAppName of ADSK_CONNECTION_POINT.
Public method | GetProperty | This method returns a specific property value.
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SaveToXml | This method save to XML all the connection point properties.
Public method | SetProperties | This method saves all the property name / value pairs to the connection point's XDATA.
Public method | SetProperty | This method assigns property name and value pair.
Public method | ToString | (Inherited from Object.)

See Also

ConnectionPointReferenceUtil Class


ConnectionPointReferenceUtil.GetProperties Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..GetProperties Method
ConnectionPointReferenceUtil Class See Also Send Feedback
This method returns all the properties stored in XDATA for the RegAppName of ADSK_CONNECTION_POINT.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Dictionary<string, string> GetProperties()
Visual Basic
Public Function GetProperties As Dictionary(Of String, String)
Visual C++
public:
Dictionary<String^, String^>^ GetProperties()

Return Value

Type: Dictionary <(Of <(<' String, String >)>)>
Dictionary of property name, value pairs.

Remarks

This method will throw an exception if the block reference does not contain the expected XDATA. Call this method within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.GetProperty Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..GetProperty Method
ConnectionPointReferenceUtil Class See Also Send Feedback
This method returns a specific property value.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetProperty(
    string propName
)
Visual Basic
Public Function GetProperty (
    propName As String
) As String
Visual C++
public:
String^ GetProperty(
    String^ propName
)

Parameters

propName
Type: System..::..String
The property name.

Return Value

Type: String
Property value as a string.

Remarks

This method will throw an exception if the block reference does not contain the expected XDATA or if the requested property is missing. It is more efficient to use GetProperties() and reuse the dictionary of property name / value pairs. Call this method within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members
Autodesk.Interop.ConnectionPoint Namespace
ConnectionPointReferenceUtil..::..GetProperties()()()()


ConnectionPointReferenceUtil.SaveToXml Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..SaveToXml Method
ConnectionPointReferenceUtil Class See Also Send Feedback
This method save to XML all the connection point properties.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveToXml(
    string strXmlFileName
)
Visual Basic
Public Sub SaveToXml (
    strXmlFileName As String
)
Visual C++
public:
void SaveToXml(
    String^ strXmlFileName
)

Parameters

strXmlFileName
Type: System..::..String
The XML file name to save to.

Remarks

This method will throw an exception if an error is encountered. Call this method within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.SetProperties Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..SetProperties Method
ConnectionPointReferenceUtil Class See Also Send Feedback
This method saves all the property name / value pairs to the connection point's XDATA.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetProperties(
    Dictionary<string, string> props
)
Visual Basic
Public Sub SetProperties (
    props As Dictionary(Of String, String)
)
Visual C++
public:
void SetProperties(
    Dictionary<String^, String^>^ props
)

Parameters

props
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
Dictionary of property name/value pairs.

Remarks

Any error setting the XDATA may trigger an exception. Call this method within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.SetProperty Method

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..SetProperty Method
ConnectionPointReferenceUtil Class See Also Send Feedback
This method assigns property name and value pair.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetProperty(
    string propName,
    string propValue
)
Visual Basic
Public Sub SetProperty (
    propName As String,
    propValue As String
)
Visual C++
public:
void SetProperty(
    String^ propName,
    String^ propValue
)

Parameters

propName
Type: System..::..String
The property name.
propValue
Type: System..::..String
The property value.

Remarks

This method will throw an exception if the block reference does not contain the expected XDATA. It is more efficient to use SetProperties() to set multiple properties. Call this method within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members
Autodesk.Interop.ConnectionPoint Namespace
ConnectionPointReferenceUtil..::..GetProperties()()()()


ConnectionPointReferenceUtil Properties

[image] [image]

Autodesk Connection Point
ConnectionPointReferenceUtil Properties
ConnectionPointReferenceUtil Class See Also Send Feedback

The ConnectionPointReferenceUtil type exposes the following members.

Properties

 | Name | Description
Public property | AttachedTo | This property gets or sets the entity the connection point is attached to.
Public property | BlockReference | This property provides the block reference that represents the connection point.
Public property | Direction | This property is a helper to quickly get or set the block reference's direction.
Public property | Guid | This property gets or sets the connection point's unique identifier.
Public property | IsValid | This property inspects the block reference to see if it is a valid connection point.
Public property | Name | This property returns the block reference's block name.
Public property | Position | This property is a helper to quickly get or set the block reference's position.

See Also

ConnectionPointReferenceUtil Class


ConnectionPointReferenceUtil.AttachedTo Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..AttachedTo Property
ConnectionPointReferenceUtil Class See Also Send Feedback
This property gets or sets the entity the connection point is attached to.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Handle AttachedTo { get; set; }
Visual Basic
Public Property AttachedTo As Handle
    Get
    Set
Visual C++
public:
property Handle AttachedTo {
    Handle get ();
    void set (Handle value);
}

Property Value

Type: Handle

Remarks

This property will throw an exception in case of error. Call this method within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.BlockReference Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..BlockReference Property
ConnectionPointReferenceUtil Class See Also Send Feedback
This property provides the block reference that represents the connection point.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BlockReference BlockReference { get; }
Visual Basic
Public ReadOnly Property BlockReference As BlockReference
    Get
Visual C++
public:
property BlockReference^ BlockReference {
    BlockReference^ get ();
}

Property Value

Type: BlockReference

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.Direction Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Direction Property
ConnectionPointReferenceUtil Class See Also Send Feedback
This property is a helper to quickly get or set the block reference's direction.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Vector3d Direction { get; set; }
Visual Basic
Public Property Direction As Vector3d
    Get
    Set
Visual C++
public:
property Vector3d Direction {
    Vector3d get ();
    void set (Vector3d value);
}

Property Value

Type: Vector3d

Remarks

The direction is not the block's rotation but rather it's normal.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.Guid Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Guid Property
ConnectionPointReferenceUtil Class See Also Send Feedback
This property gets or sets the connection point's unique identifier.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid Guid { get; set; }
Visual Basic
Public Property Guid As Guid
    Get
    Set
Visual C++
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid

Remarks

This property will throw an exception in case of error. Call this method within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.IsValid Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..IsValid Property
ConnectionPointReferenceUtil Class See Also Send Feedback
This property inspects the block reference to see if it is a valid connection point.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

Property Value

Type: Boolean

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.Name Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Name Property
ConnectionPointReferenceUtil Class See Also Send Feedback
This property returns the block reference's block name.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String

Remarks

This method does not catch exceptions that may be triggered by ObjectARX's managed APIs. The method starts a transaction to open up a block table record in read mode to obtain its name. Call this function within a try / catch block.

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members


ConnectionPointReferenceUtil.Position Property

[image]

Autodesk Connection Point
ConnectionPointReferenceUtil..::..Position Property
ConnectionPointReferenceUtil Class See Also Send Feedback
This property is a helper to quickly get or set the block reference's position.

Namespace: Autodesk.Interop.ConnectionPoint
Assembly: AdskConnectionPointMgd (in AdskConnectionPointMgd.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point3d Position { get; set; }
Visual Basic
Public Property Position As Point3d
    Get
    Set
Visual C++
public:
property Point3d Position {
    Point3d get ();
    void set (Point3d value);
}

Property Value

Type: Point3d

See Also

ConnectionPointReferenceUtil Class
ConnectionPointReferenceUtil Members