Introduzione: Software per modem Motorola SM56 - Manuale dell'utente

Funzioni principali

Grazie per aver scelto il modem SM56. Questo modem supporta gli standard di connessione V.90/V.92 e K56flex™ e garantisce connessioni ad elevata velocità tra il computer e una postazione remota. È possibile:

• Ricevere dati a una velocità massima di 56Kbps utilizzando la modalità V.90/V.92 o K56flex™, per un rapido accesso a Internet.

• Utilizzare il computer per inviare e ricevere fax, a una velocità massima di 14,4 Kbps.

• Utilizzare il computer per eseguire e ricevere chiamate come un videotelefono.

• Utilizzare il computer come segreteria telefonica (non disponibile nei modem dati/fax ).

• Utilizzare il computer come un telefono, per chiamare e rispondere alle telefonate in vivavoce (solo nei modem per dati/fax/vivavoce ).

• Consultare il manuale d'uso delle applicazioni voce del computer, per l'utilizzo delle funzioni di segreteria telefonica e vivavoce.

Che tipo di modem possiedo?

NOTA: il modello SM56 supporta connessioni a 56Kbps, ma a causa di possibili problemi di funzionamento della linea telefonica, le velocità effettive possono essere inferiori.

Funzioni principali

Il modem supporta:

• Lo standard V.90/V.92 56K e K56flex, per ottenere la massima interoperabilità con i provider di servizi Internet

• La compressione dati V.44, per raggiungere la velocità massima di download da Internet (con i provider di servizi Internet abilitati)

• L'interfaccia V.80 per applicazioni di videotelefonia compatibili con lo standard H.234

• Gli standard di modulazione V.34, V.32bis, V.32, V.23, V.22bis, V.22, V.21, Bell 212A e Bell 103

• La modalità di correzione degli errori Fax Class 1

• La modalità Fax Gruppo III V.17, V.21, V.29, V.27ter

• Il protocollo di correzione degli errori V.42, LAP-M e MNP 2-4

• I protocolli di compressione dati V.42bis e MNP 5

• Le velocità DTE da 300 bps a 115,2 Kbps

Il modem è stato progettato per essere aggiornato con facilità. È possibile aggiornare il software del modem con un semplice download da Internet, in modo da rimanere sempre aggiornati rispetto ai rapidi cambiamenti delle funzioni e delle velocità di comunicazione supportate. In molti casi, non è richiesto un nuovo hardware. Per ulteriori dettagli, rivolgersi al fornitore del modem.

Alla pagina dell'indice


ABT: Software per modem Motorola SM56 - Manuale dell'utente

Segnale ABT (Answer-Back Tone). Tonalità di risposta.


Aggiunta di comandi AT: Software per modem Motorola SM56 - Manuale dell'utente

1. Aprire il Pannello di controllo.

2. Fare doppio clic sull'icona Modem.

3. Selezionare il modem Motorola SM56.

4. Fare clic su Proprietà.

5. Selezionare Connessione.

6. Fare clic sulla scheda Avanzate.

7. Nella casella Altre impostazioni, aggiungere i comandi desiderati. Sebbene il prefisso AT non sia necessario, è possibile tuttavia inserirlo nella casella.


Compatibilità: Software per modem Motorola SM56 - Manuale dell'utente

Il modem supporta i programmi di comunicazione eseguiti:

• in Windows 98, Windows Millenium o Windows XP;

• in Windows 2000 e Windows NT 4.0;

• dal prompt dei comandi di Windows 98.


Comandi +++ (Plus-Plus-Plus): Software per modem Motorola SM56 - Manuale dell'utente

Alla pagina dell'indice

Comandi +++ (più-più-più): Software per modem Motorola SM56 - Manuale dell'utente

Questo comando, detto sequenza di Escape, ordina al modem di interrompere la trasmissione dei dati (sempre che sia in corso) e di passare in modalità comando.

Digitare tale comando sulla tastiera del computer, nella finestra del terminale dell'applicazione di comunicazione, premendo tre volte il tasto più (+).

ATTENZIONE: Non premere il tasto INVIO dopo aver digitato il comando +++. Il comando potrebbe essere cancellato.


Comandi AT e AT&: Software per modem Motorola SM56 - Manuale dell'utente

Il modem risponde alle seguenti opzioni relative ai comandi AT e AT&.

È necessario che tutti i comandi siano preceduti dalle lettere AT (oppure at), ad eccezione di A/ e di +++. Le opzioni predefinite in fabbrica sono sottolineate.

Comando Opzione Descrizione

A

(nessuna)

Risposta alla chiamata in arrivo

A/

(nessuna)

Ripetizione dell'ultimo comando

Invia nuovamente al modem il comando precedente

(non premere Invio; il comando viene eseguito alla digitazione del carattere /).

D

(nessuna)

Composizione del numero

Indica al modem di comporre il numero telefonico inserito subito dopo il comando ATD. Esempio: ATD5554678.

ATTENZIONE: Se nella modalità vivavoce si usano molteplici comandi ATD, il modem deve essere mandato in composizione cieca dopo il rilevamento del segnale di linea.

E

Invio al terminale dell'input asincrono dell'eco (tastiera)

Determina se i caratteri digitati sulla tastiera vengono visualizzati (effetto eco) nella finestra di emulazione del terminale (se attiva) o nel programma di comunicazione.

E0

Disattivo

E1

Attivo

H

Aggancio

H0

Aggancia il ricevitore (si disconnette dalla linea telefonica; riaggancia)

H1

Sgancia il ricevitore (si connette alla linea telefonica)

I

Richiesta di informazioni dal modem

I0

“5600”

I1

“255”

I2

“OK”

I3

Versione del software

I4

“OK”

I5

Motivo della disconnessione

I6

Codice Paese

I7

Codice prodotto

L

Volume altoparlante

Questo parametro determina, esclusivamente per il controllo delle chiamate in corso, il volume delle tonalità relative alla composizione, agli squilli, al segnale di occupato e alla negoziazione.

L0, L1

Basso

L2

Medio

L3

Alto

M

Controllo dell'altoparlante

M0

Inattivo

M1

Attivo solo durante l'apertura del collegamento

M2

Sempre attivo

M3

Inattivo durante la composizione del numero; attivo durante la chiamata; inattivo durante il trasferimento dei dati

O

Ritorno alla modalità in linea

Il parametro determina se il modem deve iniziare una sincronizzazione dopo essere passato dalla modalità di escape alla modalità dati oppure dopo un segno di punto e virgola inserito nelle stringhe di composizione.

O0

Nessuna sincronizzazione

O1

Sincronizzazione

O2

Avvia rinegoziazione velocità

O3

Rinegoziazione velocità in modalità silenziosa

P

P

Modalità di composizione a impulsi

Q

Visualizzazione di codici di risultato

Il modem è in grado di inviare codici di risultato e messaggi di connessione al computer, in conseguenza di una connessione o di un tentativo di connessione non riuscito al fine di determinare la velocità dati e di definire i protocolli di correzione degli errori e di compressione dati. Vedere: ATV; AT\V; ATX.

Q0

Abilita la visualizzazione

Q1

Disabilita la visualizzazione

T

T

Modalità di composizione a frequenza

Il comando indica al modem di utilizzare la composizione a frequenza DTMF .

V

Formato del codice di risultato

Determina se il modem debba inviare messaggi in formato breve o esteso all'applicazione di comunicazione, indicando lo stato della connessione, la velocità e la modalità.

V0

Restituisce un codice numerico (formato breve)

V1

Restituisce un messaggio di testo (formato esteso)

X

Selezione dei codici di risultato per la chiamata in corso

X0

No Carrier; Connect (Nessun segnale portante; Connetti). Il modem segnala l'assenza di un segnale portante, la riuscita o il fallimento della connessione, infine compone il numero senza attendere la tonalità di chiamata.

X1

No Carrier; Connect; Connect <rate> (Nessun segnale portante; Connetti; Connetti <velocità>). Il modem segnala l'assenza di un segnale portante, la riuscita o il fallimento della connessione, infine la velocità dati del computer.

X2

No Carrier; Connect; Connect <rate>; No Dial Tone (Connetti; Connetti <velocità> Segnale assente). Il modem segnala l'assenza di un segnale portante, la riuscita o il fallimento della connessione, la velocità dati del computer, infine l'assenza di segnale di linea.

X3

No Carrier; Connect; Connect <rate>; Busy-tone (Nessun segnale portante; Connetti; Connetti <velocità> Segnale di occupato). Il modem segnala l'assenza di un segnale portante, la riuscita o il fallimento della connessione, la velocità dati del computer e la presenza di un segnale di occupato.

X4

No Carrier; Connect; Connect <rate>; No Dial-tone; Busy-tone (Nessun segnale portante; Connetti; Connetti <velocità> Nessun segnale; Segnale di occupato). Il modem segnala l'assenza di un segnale portante, la riuscita o il fallimento della connessione, la velocità dati del computer, l'assenza di segnale infine la presenza di un segnale di occupato.

Z

Z

Ripristino della configurazione predefinita del modem

&C

Controllo DCD

&C0

Sempre attivo

&C1

Attivo solo in modalità dati

&D

Controllo DTR

Determina il modo in cui il modem risponde al segnale DTR inviato dal DTE.

&D0

Ignora DTR

&D1

Abilita la modalità comandi quando il segnale DTR passa da attivo a disattivo.

&D2

Si disconnette la chiamata quando il segnale DTR passa da attivo a disattivo.

&D3

Reimposta i parametri del modem alla configurazione predefinita quando il segnale DTR passa da attivo a disattivo.

&F

Inizializza il modem utilizzando la configurazione predefinita del produttore.

&G

Tonalità di controllo

&G0

Inattivo

&G1

Tonalità di controllo a 550 Hz

&G2

Tonalità di controllo a 1800 Hz

&I

Composizione a livello TX

&In

Livello n; n è compreso tra 0 e 15. Valore predefinito = 9

&I99

Livello automatico

&P

Ciclo ad impulsi

Utilizzato quando al modem è richiesto di utilizzare la composizione a impulsi.

&P0

40/60 Make/Break Ratio

&P1

33/67 Make/Break Ratio

&P2

38/62 Make/Break Ratio

&R

Controllo CTS

&R0

Normale

&R1

Sempre attivo

&S

Controllo DSR

&S0

Sempre attivo

&S1

Attivo quando il modem riconosce il terminale remoto

&T

Test

&T0

Termina test

&T1

Avvio del test di loopback analogico locale

Colleghi la linea telefonica al modem prima di usando questo ordine.

Impostare S-Register 46=23 (ATS46=23) prima di eseguire &T1.

&V

Stato del modem

&V0

Rapporto in formato breve

&V1

Rapporto sulla connessione corrente o sull'ultima connessione

&V2

Rapporto in formato esteso

Tabella 1: Comandi AT e AT&


Comandi AT* (asterisco): Software per modem Motorola SM56 - Manuale dell'utente

Alla pagina dell'indice

Comandi AT*: Software per modem Motorola SM56 - Manuale dell'utente

Il modem risponde alle seguenti opzioni relative ai comandi AT*.

È necessario che tutti i comandi siano preceduti dalle lettere AT (oppure at), ad eccezione di A/ e di +++. Le opzioni predefinite in fabbrica sono sottolineate.

Comando | Opzione | Descrizione
*DD |  | Attesa di composizione Specifica il tempo di attesa quando il modem incontra una W o w durante l'elaborazione di una stringa di composizione.
 | *DD0 | 2 secondi
 | *DD1 | 3 secondi
 | *DD2 | 4 secondi
 | *DD3 | 5 secondi
 | *DD4 | 12 secondi
 | *DD5 | 15 secondi
 | *DD6 | 20 secondi
 | *DD7 | 30 secondi
 | *DD8 | 40 secondi
*LS |  | Protocollo di funzionamento a bassa velocità Consente di selezionare un protocollo di comunicazione per comunicare con modem a bassa velocità o meno recenti.
 | *LS0 | Bell 103
 | *LS1 | ITU-T V.21 (standard internazionale)
 | *LS2 | Bell 103 o ITU-T V.21 (determinazione automatica)
*MM |  | Modalità di modulazione
 | *MM0 | Modulazione automatica V.34
 | *MM1 | V.21
 | *MM2 | Bell 103
 | *MM4 | V.22/Bell 212
 | *MM5 | V.22bis
 | *MM6 | V.23
 | *MM10 | Solo V.32
 | *MM11 | V.32 bis
 | *MM12 | Solo V.34
 | *MM13 | Solo K56flex™
 | *MM14 | Modulazione automatica K56flex™
 | *MM15 | Solo V.90
 | *MM16 | V.90 Automatico
 | *MM17 | Solo V.92
 | *MM18 | V.90 Automatico

Tabella 1: Comandi AT* (asterisco)


Comandi AT - Nozioni fondamentali: Software per modem Motorola SM56 - Manuale dell'utente

I comandi AT sono utilizzati per controllare e monitorare il modem. In genere, l'applicazione di comunicazione li invia automaticamente, pertanto non è necessario che l'utente conosca tali comandi e le relative opzioni.

In ogni caso, se si desidera personalizzare la configurazione del modem in base ad una particolare applicazione oppure ottimizzarne le prestazioni, è possibile inviare direttamente i comandi tramite il programma di comunicazione. La maggior parte di tali programmi include una voce di menu o un'opzione che consente di inviare comandi AT estesi o personalizzati. Consultare la documentazione allegata al proprio programma di comunicazione.

È inoltre possibile configurare il modem inviando comandi AT direttamente da una semplice applicazione di emulazione di terminale. Un esempio di applicazione di questo tipo è HyperTerminal, presente su qualsiasi computer che utilizzi Windows.

Per inviare un comando AT da un'applicazione di emulazione di terminale, è necessario assicurarsi che il modem sia in modalità comandi (che consente di rilevare e rispondere ai comandi), anzichè in modalità dati (che consente di trasmettere e ricevere dati). Per passare dalla modalità comandi alla modalità dati, digitare +++. Non è necessario premere INVIO.

Quando si utilizzano comandi AT, è necessario seguire poche regole essenziali:

• i comandi AT possono essere digitati usando lettere maiuscole, minuscole o entrambe;

• ogni comando AT comincia con le lettere "AT" , a eccezione di A/ e di +++;

• il tasto usato con le funzioni del tasto INVIO è indicato in S-Register S3;

• la lunghezza massima per ogni comando è di 64 caratteri.

È possibile digitare più comandi AT per riga e creare una sequenza di comandi preceduti da un unico “AT” posto all'inizio. In ogni caso, alcuni comandi devono necessariamente essere collocati all'inizio o alla fine della riga di comando.


Comandi AT% e AT\ : Software per modem Motorola SM56 - Manuale dell'utente

Alla pagina dell'indice

Comandi AT% (percentuale) e AT\ (barra rovesciata): Software per modem Motorola SM56 - Manuale dell'utente

Il modem risponde alle seguenti opzioni relative ai comandi AT% e AT\.

È necessario che tutti i comandi siano preceduti dalle lettere AT (oppure at), ad eccezione di A/ e di +++. Le opzioni predefinite in fabbrica sono sottolineate.

Comando | Opzione | Descrizione
%B |  | Velocità massima di modulazione Imposta la velocità massima del modem quando si collega in modalità di modulazione dati, al fine di eseguire operazioni quali l'accesso a Internet o il trasferimento di file.
 | %B0 | Velocità massima modem supportata dalla periferica
 | %B1 | 300 bps
 | %B2 | 1,2 Kbps
 | %B3 | 2,4 Kbps
 | %B4 | 4,8 Kbps
 | %B6 | 9,6 Kbps
 | %B7 | 7,2 Kbps
 | %B8 | 12,0 Kbps
 | %B9 | 14,4 Kbps
 | %B11 | 16,8 Kbps
 | %B12 | 19,2 Kbps
 | %B13 | 21,6 Kbps
 | %B14 | 24,0 Kbps
 | %B15 | 26,4 Kbps
 | %B16 | 28,8 Kbps
 | %B17 | 31,2 Kbps
 | %B18 | 33,6 Kbps
 | %B19 | 32,0 Kbps
 | %B20 | 34,0 Kbps
 | %B21 | 36,0 Kbps
 | %B22 | 38,0 Kbps
 | %B23 | 40,0 Kbps
 | %B24 | 42,0 Kbps
 | %B25 | 44,0 Kbps
 | %B26 | 46,0 Kbps
 | %B27 | 48,0 Kbps
 | %B28 | 50,0 Kbps
 | %B29 | 52,0 Kbps
 | %B30 | 54,0 Kbps
 | %B31 | 56,0 Kbps
 | %B32 | 58,0 Kbps
 | %B33 | 60,0 Kbps
 | %B34 | 28.000 bps
 | %B35 | 29.333 bps
 | %B36 | 30.666 bps
 | %B37 | 33.333 bps
 | %B38 | 34.666 bps
 | %B39 | 37.333 bps
 | %B40 | 38.666 bps
 | %B41 | 41.333 bps
 | %B42 | 42.666 bps
 | %B43 | 45.333 bps
 | %B44 | 46.666 bps
 | %B45 | 49.333 bps
 | %B46 | 50.666 bps
 | %B47 | 53.333 bps
 | %B48 | 54.666 bps
%C |  | Modalità di compressione dati (DC) Determina se il modem implementa o meno i metodi di incremento della velocità effettiva di trasferimento dei dati, riducendo il numero di bit usati per rappresentare i dati stessi.
 | %C0 | Disabilita compressione
 | %C1 | Abilita compressione
%D |  | Ritardo del buffer di disconessione Controlla il tempo tra il rilevamento di una richiesta di disconnessione e la disconnessione del modem dalla linea telefonica.
 | %D0 | Disabilita ritardo
 | %Dn | Ritardo di n secondi (n è compreso tra 1 e 255)
%L |  | Velocità minima di modulazione Imposta la velocità minima utilizzata dal modem quando è connesso in modalità di modulazione dati.
 | %L0 | Velocità minima del modem supportata dalla periferica (300 bps)
 | %L1 | 300 bps
 | %L2 | 1,2 Kbps
 | %L3 | 2,4 Kbps
 | %L4 | 4,8 Kbps
 | %L7 | 7,2 Kbps
 | %L6 | 9,6 Kbps
 | %L8 | 12,0 Kbps
 | %L9 | 14,4 Kbps
 | %L11 | 16,8 Kbps
 | %L12 | 19,2 Kbps
 | %L13 | 21,6 Kbps
 | %L14 | 24,0 Kbps
 | %L15 | 26,4 Kbps
 | %L16 | 28,8 Kbps
 | %L17 | 31,2 Kbps
 | %L18 | 33,6 Kbps
 | %L19 | 32,0 Kbps
 | %L20 | 34.0 Kbps
 | %L21 | 36,0 Kbps
 | %L22 | 38,0 Kbps
 | %L23 | 40,0 Kbps
 | %L24 | 42,0 Kbps
 | %L25 | 44,0 Kbps
 | %L26 | 46,0 Kbps
 | %L27 | 48,0 Kbps
 | %L28 | 50,0 Kbps
 | %L29 | 52,0 Kbps
 | %L30 | 54,0 Kbps
 | %L31 | 56,0 Kbps
 | %L32 | 58,0 Kbps
 | %L33 | 60,0 Kbps
 | %L34 | 28.000 bps
 | %L35 | 29.333 bps
 | %L36 | 30.666 bps
 | %L37 | 33.333 bps
 | %L38 | 34.666 bps
 | %L39 | 37.333 bps
 | %L40 | 38.666 bps
 | %L41 | 41.333 bps
 | %L42 | 42.666 bps
 | %L43 | 45.333 bps
 | %L44 | 46.666 bps
 | %L45 | 49.333 bps
 | %L46 | 50.666 bps
 | %L47 | 53.333 bps
 | %L48 | 54.666 bps
\K |  | Metodo di gestione delle interruzioni
 | \K1 | Distruttivo accelerato
 | \K3 | Non distruttivo accelerato
 | \K5 | Non distruttivo non accelerato
\N |  | Modalità di correzione degli errori (CE)
 | \N0 | Normale
 | \N1 | Diretta
 | \N4 | Solo LAP-M
 | \N6 | Affidabile
 | \N7 | Auto-affidabile
\Q |  | Controllo del flusso DTE
 | \Q0 | Disabilitato
 | \Q1 | XON/XOFF (controllo di flusso software)
 | \Q3 | RTS/CTS (controllo di flusso hardware)
\T |  | Disconnessione in caso di inattività DTE
 | \T0 | Disabilitata
 | \Tn | Si disconnette dopo n minuti di inattività del computer; n è compreso tra 0 e 255
\V |  | Formato del messaggio di connessione Determina il tipo di messaggi che saranno generati dal modem al momento della connessione.
 | \V0 | Visualizza velocità DTE
 | \V1 | DTE con messaggio EC /DC
 | \V2 | Visualizza velocità DCE
 | \V3 | DCE con messaggio EC/DC
 | \V4 | DCE con modulazione & messaggio EC/DC

Tabella 1: Comandi AT% (percentuale) e AT\ (barra rovesciata)


Comandi AT+ (più): Software per modem Motorola SM56 - Manuale dell'utente

Alla pagina dell'indice

Comandi AT+: Software per modem Motorola SM56 - Manuale dell'utente

Il modem risponde alle seguenti opzioni relative al comando AT+. Tutti i comandi devono essere preceduti dalle lettere AT (oppure at) ad eccezione di A/ e di +++.

Le opzioni predefinite in fabbrica sono sottolineate.

Comandi AT che cominciano con :

+D controllo compressione dati

+F controllo funzionamento dell'applicazione fax

Questi comandi sono utilizzati principalmente da applicazioni software.

Comando | Opzione | Descrizione
+A8E |  | Configurazione V.8
 | +A8=a,b,c,d |
 | Opzioni a: | Specifica le opzioni di negoziazione di origine V.8
 | 0 | Disabilitata
 | 1 | Abilita la negoziazione di origine V.8 controllata dal computer
 | 6 | Abilita la negoziazione di origine V.8 controllata dal computer con indicazioni +A8x
 | Opzioni b: | Specifica le opzioni di negoziazione di risposta V.8
 | 0 | Disabilitata
 | 1 | Abilita la negoziazione di risposta V.8 controllata dal computer
 | 5 | Abilita la negoziazione di risposta V.8 controllata dal computer con indicazioni +A8x
 | Opzioni c: | Specifica le opzioni Signal Call Function Octet V.8 CI
 | 00h - FFh, valore predefinito=00h |
 | Opzioni d: | Specifica le opzioni di controllo V.8
 | 0 | Disattivato
 | 1 | Abilitato, controllo modem
 | 2 | Abilitato, controllo computer
+A8T |  | Controllo messaggio e segnale V.8bis
 | +A8T=a,b,c,d,e,f |
 | Opzioni a: | Specifica al segnale V.8bis da trasmettere
 | 0 | Nessuna
 | 1 | Inizializzazione di MRe
 | 2 | Inizializzazione di MRd
 | 3 | Inizializzazione di Cre, potenza ridotta
 | 4 | Inizializzazione di Cre, potenza elevata
 | 5 | Inizializzazione di Crd
 | 6 | Inizializzazione di Esi
 | 7 | Risposta di MRd, potenza ridotta
 | 8 | Risposta di MRd, potenza elevata
 | 9 | Risposta di CRd
 | 10 | Risposta di ESr
 | Opzioni b: | Specifica a V.8 di trasmettere il messaggio 1
 |  | Stringa codificata ottetto esadecimale
 | Opzioni c: | Specifica a V.8bis di trasmettere il messaggio 2
 |  | Stringa codificata ottetto esadecimale
 | Opzioni d: | Specifica il rilevamento di un segnale V.8bis
 | 0 | Abilita il rilevamento del segnale di inizializzazione V.8bis
 | 1 | Abilita il rilevamento del segnale di risposta V.8bis
 | 2 | Abilita il rilevamento di entrambi i segnali V.8bis
 | Opzioni e: | Specifica il rilevamento dei messaggi V.8bis
 | 0 | Disabilita rilevamento
 | 1 | Abilita rilevamento
 | Opzioni f: | Specifica la durata del messaggio V.8bis
 | 0 | Nessun periodo di tempo tra la trasmissione del segnale e i messaggi
 | 1 | Ritardo di 1,5 secondi tra la trasmissione del segnale e un messaggio
+DR |  | Rapporto compressione dati (DC)
 | +DR=0 | Disattivato
 | +DR=1 | Attivato
+DS |  | Controllo di compressione dati
 | +DS=p,q,r,s |
 | Opzioni p: | Specifica la direzione on/off della compressione
 | 0 | Nessuna compressione
 | 1 | Solo direzione Tx
 | 2 | Solo direzione Rx
 | 3 | Entrambe le direzioni; accetta tutte le direzioni
 | Opzioni q: | Specifica la negoziazione
 | 0 | Non disconnette se la compressione dati non viene negoziata per l'opzione di direzione
 | 1 | Disconnette se la compressione dati non viene negoziata per l'opzione di direzione
 | Opzioni r: | Specifica la dimensione massima del dizionario
 | 512 - 65535 | Valore predefinito = 2048
 | Opzioni s: | Specifica la dimensione massima della stringa
 | 6 - 250 | Valore predefinito = 32
+EB |  | Controllo gestione dell'interruzione
 | +EB=p,q r |
 | Opzioni p: | Specifica la selezione di interruzione
 | 0 | Ignora interruzione
 | 1 | Non accelerato, non distruttivo
 | 2 | Accelerato, non distruttivo
 | 3 | Accelerato, distruttivo
 | Opzioni q : | Specifica il controllo della durata dell'interruzione
 | 0 | La trasmissione di V.42 L-SIGNAL non indica la lunghezza dell'interruzione
 | 1 | La trasmissione di V.42 L-SIGNAL indica la lunghezza dell'interruzione
 | Opzioni r: | Specifica la lunghezza dell'interruzione predefinita
 | 0 | Interruzione non trasmessa al computer
 | 1- 254, valore predefinito=100 | Lunghezza interruzione, incrementi di 0,01 secondi
+ER |  | Rapporto sul controllo di errore
 | +ER=a |
 | Opzioni a: | Specifica l'attività di controllo di errore del modem
 | 0 | Disattivato
 | 1 | Attivato: il modem invia al computer uno dei seguenti messaggi, seguito da un messaggio di connessione. Il messsaggio specifica il protocollo di correzione errori negoziato: +ER:NONE +ER:LAPM +ER:ALT
+ES |  | Controllo correzione errori (EC)
 | +ES=p,q r |
 | Opzioni p: | Specifica la modalità di richiesta di correzione dell'errore originata dal modem
 | 0 | Modalità diretta
 | 1 | Modalità normale
 | 2 | Solo LAP-M
 | 3 | LAP-M o MNP
 | 4 | Solo MNP
 | 6 | Inizializza la modalità di accesso sincrono quando viene stabilita la connessione
 | Opzioni q: | Specifica la modalità di correzione degli errori a cui è tornato il modem che risponde
 | 0 | Modalità EC opzionale, ritorno alla modalità normale
 | 1 | Modalità EC opzionale, ritorno alla modalità diretta
 | 2 | Modalità EC obbligatoria (LAP-M o MNP)
 | 3 | Modalità EC obbligatoria (solo LAP-M)
 | 4 | Modalità EC obbligatoria (solo MNP)
 | Opzioni r: | Specifica la modalità di ritorno alla correzione di errore originata dal modem
 | 0 | Modalità diretta
 | 1 | Modalità normale
 | 2 | Modalità EC opzionale, ritorno alla modalità normale
 | 3 | Modalità EC opzionale, ritorno alla modalità diretta
 | 4 | Modalità EC obbligatoria (LAP-M o MNP)
 | 5 | Modalità EC obbligatoria (solo LAP-M)
 | 6 | Modalità EC obbligatoria (solo MNP)
 | 8 | Inizializza la modalità di accesso sincrono al momento della connessione
+ESA |  | Configurazione della modalità di accesso sincrono
 | +ESA=a,b,c,d,e,f |
 | Opzioni a: | Specifica l'inattività della sottomodalità trasparente
 | 0 | Il computer trasmette una sequenza 8 bit SYN quando inattivo. Il computer non ricerca la sequenza di sincronizzazione
 | Opzioni b: | Specifica inattività nella sottomodalità relativa ai frame
 | 0 | Il computer trasmette indicatori HDLC se inattivo
 | Opzioni c: | Specifica under-run e over-run nella sottomodalità relativa ai frame
 | 0 | Il computer trasmette il comando Interrompi in un under-run all'interno di un frame
 | 1 | Il computer trasmette un indicatore in un under-run all'interno di un frame e notifica al modem eventuali under-run o over-run
 | Opzioni d | Specifica il controllo half-duplex. Non disponibile.
 | Opzioni e | Specifica il tipo di codice di risposta ciclica (CRC)
 | 0 | Disattivato. Nessuna generazione o controllo CRC.
 | 1 | Nella sottomodalità relativa ai frame, il computer genera un codice CRC a 16 bit in direzione di trasmissione e il modem genera un codice CRC a 16 bit in direzione di ricezione.
 | Opzioni f: | Specifica le opzioni di non ritorno a zero (NRZI)
 | 0 | Codifica e decofica NRZI disabilitate.
+ETBM |  | Controllo ritardo buffer di disconnessione
 | +ETBM=p,q r |
 | Opzioni p: | Specifica il ritardo del buffer di disconnessione in caso di dati in corso di trasmissione
 | 0 | Ignora i dati presenti nel buffer e si disconnette
 | 1 | Effettua un tentativo di trasmissione fino al completamento della trasmissione dei dati, quindi si disconnette. Ignora il timer.
 | 2 | Effettua un tentativo di trasmissione fino al completamento della trasmissione dei dati oppure fino alla scadenza del timer.
 | Opzioni q: | Specifica la durata del buffer di disconnessione con dati in ricezione in sospeso
 | 0 | Ignora i dati presenti nel buffer e si disconnette
 | 1 | Effettua un tentativo di trasmissione fino alla consegna dei dati, quindi si disconnette. Ignora il timer.
 | 2 | Effettua un tentativo di trasmissione fino al completamento della trasmissione dei dati o fino alla scadenza del timer.
 | Opzioni r: 1-255, valore predefinito=0 | Timer del ritardo del buffer di disconnessione, incrementi di 1 secondo
+FCLASS |  | Modalità fax/dati
 | +FCLASS=0 | Modalità dati
 | +FCLASS=1 | Fax Class 1
 | +FCLASS=8 | Modalità voce (Non disponibile nei modem Dati/Fax e Dati/fax/TAM.)
+FLO |  | Controllo di flusso per il fax
 | +FLO=0 | Nessuna
 | +FLO=1 | XON/XOFF
 | +FLO=2 | RTS/CTS
+FMI? |  | ID produttore
+FMM? |  | ID modem
+FMR? |  | Livello di revisione
+FRH |  | Modalità di ricezione HDLC (High-Level Data Link Control) - Imposta la modalità e la velocità di trasmissione/ricezione dei fax
 | +FRH=3 | V.21 a 300 bps
 | +FRH=24 | V.27ter a 2,4 Kbps
 | +FRH=48 | V.27ter a 4,8 Kbps
 | +FRH=72 | V.27ter a 7,2 Kbps
 | +FRH=73 | V.27ter a 7,2 KBPS con tempi lunghi di sincronizzazione iniziale
 | +FRH=74 | V.27ter a 7,2 Kbps con tempi brevi di sincronizzazione iniziale
 | +FRH=96 | V.29 a 9.6 Kbps
 | +FRH=97 | V.17 a 9,6 Kbps con tempi lunghi di sincronizzazione iniziale
 | +FRH=98 | V.17 a 9.6 Kbps con tempi brevi di sincronizzazione iniziale
 | +FRH=121 | V.17 a 12,0 Kbps con tempi lunghi di sincronizzazione iniziale
 | +FRH=122 | V.17 a 12,0 Kbps con tempi brevi di sincronizzazione iniziale
 | +FRH=145 | V.17 a 14,4 Kbps con tempi lunghi di sincronizzazione iniziale
 | +FRH=146 | V.17 a 14,4 Kbps con tempi brevi di sincronizzazione iniziale
+FRM | +FRM | Modalità di ricezione Imposta la modalità di modulazione per la ricezione di fax
 | +FRMm | Utilizza la modalità m; vedere sopra le opzioni della modalità per +FRH.
+FRS > |  | Attesa del silenzio
 | +FRSn | Attende (n*10) ms; n è compreso tra 0 e 255
+FTH | +FTH | Modalità di trasmissione HDLC (High-Level Data Link Control)
 | +FTHmode | Utilizza la modalità mode; vedere sopra le opzioni per +FRH.
+FTM | +FTM | Modalità di trasmissione - Imposta la modalità di modulazione per la trasmissione di fax
 | FTMmode | Utilizza la modalità mode; vedere sopra le opzioni per +FRH.
+FTS |  | Pausa di trasmissione
 | +FTSn | Sospende la trasmissione per (n*10) ms; n è compreso tra 0 e 255
+GCAP |  | Rapporto sulle funzionalità
 | +GCAP | Visualizza le funzionalità del modem
+GCI |  | Paese di installazione
 | +GCI=a | Imposta il Paese in cui il modem viene installato
 | 00 | Giappone
 | 04 | Repubblica Federale Tedesca
 | 07 | Argentina
 | 09 | Australia
 | 0A | Austria
 | 0F | Belgio
 | 16 | Brasile
 | 1B | Bulgaria
 | 20 | Canada
 | 25 | Cile
 | 26 | Cina
 | 27 | Colombia
 | 2E | Repubblica Ceca
 | 2D | Cipro
 | 31 | Danimarca
 | 3C | Finlandia
 | 3D | Francia
 | 42 | Repubblica Federale Tedesca
 | 50 | Hong Kong
 | 57 | Irlanda
 | 58 | Israele
 | 59 | Italia
 | 5E | Giordania
 | 61 | Corea
 | 68 | Liechtenstein
 | 6C | Malesia
 | 70 | Malta
 | 7B | Paesi Bassi
 | 82 | Norvegia
 | 8B | Portogallo
 | 8C | Porto Rico
 | 9C | Singapore
 | 9F | Sud Africa
 | A0 | Spagna
 | A5 | Svezia
 | A6 | Svizzera
 | A9 | Thailandia
 | AE | Turchia
 | B4 | Regno Unito
 | B5 | Stati Uniti
 | BB | Venezuela
 | BC | Vietnam
+GMI |  | Richiesta ID produttore
 | +GMI? | Visualizza informazioni sul produttore del modem
+GMM |  | Richiesta ID modello
 | +GMM? | Visualizza informazioni sul modello del modem
+GMR |  | Richiesta numero di revisione software
 | +GMR? | Visualizza il numero di revisione del software del modem
+IFC |  | Controllo di flusso
 | +IFC=p,q |
 | Opzioni p: | Specifica il metodo di controllo di flusso utilizzato dal computer per trasferire i dati al modem (downstream)
 | 0 | Nessuna
 | 1 | Controllo di flusso XON/XOFF, senza pass-through
 | 2 | Contollo di flusso RTS
 | 3 | Controllo di flusso XON/XOFF, con pass-through
 | Opzioni q: | Specifica il metodo di controllo di flusso utilizzato dal modem per trasferire i dati dal modem stesso (a monte)
 | 0 | Nessuna
 | 1 | Controllo di flusso XON/XOFF, senza pass-through
 | 2 | Controllo di flusso CTS
+ILRR |  | Rapporto velocità del computer in locale
 | +ILRR=0 | Disattivato
 | +ILRR=1 | Attivato
+ITF |  | Soglie di controllo di flusso in trasmissione (V.80)
 | +ITF=a,b |
 | Opzioni a: | Specifica la soglia, in ottetti, alla quale il modem disattiva il controllo di flusso di trasmissione
 | 0-2047 valore predefinito=255 |
 | Opzioni b: | Specifica la soglia, in ottetti, alla quale il modem attiva il controllo di flusso in trasmissione
 | 0-2047 valore predefinito=255 |
+MR |  | Rapporto modalità di modulazione
 | +MR=0 | Disattivato
 | +MR=1 | Attivato
+MS |  | Controllo modulazione
 | +MS=p,q,r,s,t,u |
 | Opzioni p: | Specifica la modalità di modulazione
 | V21 | V.21
 | V22 | V.22
 | V22B | V.22bis
 | V23C | V.23c
 | V32 | V.32
 | V32B | V.32bis
 | V34 | V.34
 | K56FLEX | K56flex™
 | V90 | V.90
 | V92 | V.92
 | Opzioni q: | Specifica l'opzione di selezione automatica della modalità
 | 0 | Disattivato
 | 1 | Attivato
 | Opzioni r: | Specifica la velocità dati minima in direzione Tx
 | 0 | Utilizza la velocità minima della modalità di modulazione specificata (300 bps)
 | 300 - 33600 | bps
 | Opzioni s : | Specifica la velocità dati massima in direzione Tx
 | 0 | Utilizza la velocità massima della modalità di modulazione specificata
 | 300 - 33600 | bps
 | Opzioni t: | Specifica la velocità dati minima in direzione Rx
 | 0 | Utilizza la velocità minima della modalità di modulazione specificata
 | 300 - 60000 | bps
 | Opzioni u : | Specifica la velocità dati massima in direzione Rx
 | 0 | Utilizza la velocità massima della modalità di modulazione specificata
 | 300 - 60000 | bps
+VCID |  | Funzione Identificazione chiamata
 |  | Questa opzione diviene operativa solo dove la funzione è supportata. I modem Data/Fax non supportano questa funzione.
 | +VCID=0 | Disattiva
 | +VCID=1 | Attiva
 | +VCID=? | Visualizza lo stato della ID utente (mostra 0 o 1)
+VDR |  | Controllo e Reporting Squillo distinto
 |  | Questa opzione diviene operativa solo dove la funzione è supportata. I modem Data/Fax non supportano questa funzione.
 | +VDR=m,n | NOTA: Se Distinctive Ring è attivato, il primo squillo notificato dal modem può non essere corretto.
 | Opzioni m: | Specifica il controllo
 | 0 | Disattiva
 | 1 | Attiva
 | Opzioni n: | Specifica reporting
 | 0 | Produce il resoconto DROFF/DRON senza RING
 | 1-255 | Produce DROFF/DRON, seguito da RING dopo un ritardo di n/10 secondi
+VEM |  | Controllo del rapporto degli eventi e degli eventi mappati
Solo per modem dati/fax/vivavoce
 |  | Maschera di controllo degli eventi mappati su bit. Fare riferimento a Parola di rapporto degli eventi.
+VGR |  | Ricezione del guadagno
Solo per modem dati/fax/vivavoce
 | 0 | Controllo automatico del guadagno
 | 1-255 | Intervallo relativo, in cui 128 indica un valore nominale.
+VGT |  | Volume di trasmissione
Solo per modem dati/fax/vivavoce
 | 1-255 | Intervallo relativo, in cui 128 indica un valore nominale.
+VIP |  | Inizializzazione dei parametri vocali
Solo per modem dati/fax/vivavoce
 |  | Imposta i parametri di vivavoce per le opzioni predefinite in fabbrica.
+VLS |  | Selezione origine e destinazione analogica
Solo per modem dati/fax/vivavoce
 | 0 | DCE (modem) agganciato
 | 1 | DCE non agganciato, DCE collegato a telco
 | 8 | DCE agganciato, DCE collegato all'altoparlante
 | 9 | vivavoce con modalità di muto attivata
 | 11 | DCE agganciato, DCE collegato al microfono
 | 13 | DCE non agganciato, DCE collegato a telco, altoparlante e microfono (vivavoce)
+VNH |  | Controllo di riaggancio automatico
Solo per modem dati/fax/vivavoce
 | +VNH=0 | Mantiene i riagganci automatici
 | +VNH=1 | Disattiva il riaggancio automatico iniziato da DCE
 | +VNH=2 | Disattiva tutti i riagganci automatici
+VPR |  | Velocità DTE-DCE voce
Solo per modem dati/fax/vivavoce
 | +VPR=0 | Autobaud
+VRA |  | Timer di Ringback
Solo per modem dati/fax/vivavoce
 |  | Se, dopo aver rilevato un primo ringback, non si verificano ulteriori ringback dopo n/10 secondi, operare come se la periferica remota avesse risposto alla chiamata.
 | +VRA=n | Se non viene ricevuto alcun ringback dopo n/10 secondi, operare come se la periferica remota avesse risposto alla chiamata; n = 0-255
 |  | Mancata esecuzione del ringback
 | +VRN=n | Dopo n/10 secondi, usare come se non fosse mai avvenuto il ringback; n = 0-255
+VRX |  | Modalità di ricezione vocale
Solo per modem dati/fax/vivavoce
 |  | Determina se il modem genera un segnale periodico, udible da entrambe le parti in modalità vivavoce, indicando così che la chiamata viene registrata.
 |  | NOTE: non occorre ripristinare l'altoparlante successivamente alla registrazione in linea o alla riproduzione del messaggio. La velocità in baud non è impostata prima dei comandi StartPlay e StartRecord. La velocità non è ripristinata dopo i comandi StopPlay e StopRecord.
 | +VRX or +VRX=0 | Produce una tonalità DCE periodica durante la registrazione
 | +VRX=1 | Disattiva la produzione della tonalità DCE periodica durante la registrazione
+VSD |  | Proprietà di rilevamento di assenza di segnale remoto
Solo per modem dati/fax/vivavoce
 | +VSD=m,n | Viene usato in modalità di segreteria telefonica. Specifica la soglia di volume e di durata che determina se il dispositivo remoto ha riagganciato.
 | Opzioni m: | Specifica il livello di individuazione del silenzio
 | 0 | Usa il valore corrente di +VSM; oppure, se il valore corrente di +VSM è 0, usa 128.
 | 127 | Soglia inferiore (la più sensibile)
 | 128 | Soglia media
 | 129 | Soglia superiore (la meno sensibile)
 | Opzioni n: | Specifica la durata dell'individuazione del silenzio
 | 0 | Disattiva
 | 1-255 | Individua il silenzio per una durata di n/10 secondi; n = 0-255
 | 60 | Impostazione predefinita = 6 secondi
+VSM |  | Proprietà di compressione vocale
Solo per modem dati/fax/vivavoce
 | +VSM=m,n,p,q | Specifica i parametri di compressione di vivavoce
 | Opzioni m: | Specifica il metodo di compressione
 | 128 | PCM
 | 129 | ADPCM
 | Opzioni n: | Specifica la velocità di campionamento per la determinazione dell'opportunità o meno della compressione
 | 8000 | 8000 Hz
 | Opzioni p: | Il parametro p specifica la compressione e l'espansione dei periodi di silenzio. Questi parametri non sono introdotti nella versione 1.0. Si possono lasciare vuoti o inserire il valore 0.
 | 0 | Disattiva
 | opzioni q: | Il parametro q specifica la compressione e l'espansione dei periodi di silenzio. Questi parametri non sono introdotti nella versione 1.0. Si possono lasciare vuoti o inserire il valore 0.
 | 0 | Disattiva
+VTD |  | Durata della tonalità Dual Tone Multi-Frequency (DTMF)
Solo per modem dati/fax/vivavoce
 | +VTDn | Genera una tonalità per n/100 secondi; n = 0-255. Valore predefinito = 100.
+VTS |  | Proprietà di generazione della tonalità DTMF
Solo per modem dati/fax/vivavoce
 |  | +VTS accetta opzioni multiple, separate da virgole, di qualsiasi dei tipi seguenti. Usare le parentesi quadre e graffe come indicato più oltre.
 | D | Genera la tonalità predefinita DTMF, di durata predefinita.
 | {t,n} | t specifica una tonalità DTMF; t = 0-9 n specifica una durata della tonalità n/100 secondi; n = 1-500
 | {f,g,n} | f e g specificano una coppia di tonalità, f Hz e g Hz; all'interno dell'intervallo n Specifica la durata della coppia di tonalità n/100 secondi; n = 1-500
 | Esempio: | AT+VTS=4,{},[1000,1300,50],8,{*,5},[,,100],5 Questo esempio specifica la sequenza seguente: 1. Eseguire DTMF 4 per la durata memorizzata in +VTD 2. Eseguire silence per la durata memorizzata in +VTD 3. Eseguire la coppia di tonalità a 1000 Hz e 1300 Hz per 500 ms 4. Eseguire DTMF 8 per la durata memorizzata in +VTD 5. Eseguire DTMF * per 50 ms 6. Eseguire silence per 1 secondo 7. Eseguire DTMF 5 per la durata memorizzata in +VTD
+VTX |  | Modalità Enter Voice-Transmission
Solo per modem dati/fax/vivavoce
 |  | NOTE: non occorre ripristinare l'altoparlante successivamente alla registrazione in linea o alla riproduzione del messaggio. La velocità in baud non è impostata prima dei comandi di StartPlay e StartRecord. La velocità non è ripristinata dopo i comandi StopPlay e StopRecord.


ATH: Software per modem Motorola SM56 - Manuale dell'utente

Segnale ATH (Attention Hung-up). Richiede al modem di disconnettersi dalla linea.


Comandi ATS (S-Register): Software per modem Motorola SM56 - Manuale dell'utente

Il modem risponde alle seguenti opzioni relative al comando ATS.

È necessario che tutti i comandi siano preceduti dalle lettere AT (oppure at), ad eccezione di A/ e di +++. Le opzioni predefinite in fabbrica sono sottolineate.

S-Register | Opzione | Descrizione
S0 |  | Risposta automatica dopo un numero specificato di squilli
 | S0=0 | Disabilitata
 | S0=n | Risposta dopo lo squillo n; n è compreso tra 0 e 255
S1 |  | Conteggio degli squilli
 | S1=n | Conta il numero di squilli della chiamata in arrivo. Se il modem è configurato per rispondere automaticamente (S0 impostato su opzione diverso da zero), per S1=S0, il modem risponde alla chiamata.
S2 |  | Selezione del carattere per il comando Escape
 | S2=n | Specifica il carattere ASCII per il comando Esc; n compreso tra 0 e 255. Valore predefinito = 43 (+)
S3 |  | Selezione del carattere di ritorno a capo
 | S3=n | Specifica il carattere ASCII per la funzione di ritorno a capo; n compreso tra 0 e 127. Valore predefinito = 13 (CR)
S4 |  | Selezione del carattere di avanzamento di riga
 | S4=n | Specifica il carattere ASCII per la funzione di avanzamento riga; n compreso tra 0 e 127. Valore predefinito = 10 (LF)
S5 |  | Selezione del carattere di ritorno unitario
 | S5=n | Specifica il carattere ASCII per la funzione di ritorno unitario; n compreso tra 0 e 127. Valore predefinito = 8 (BS)
S6 |  | Composizione cieca
 | S6=n | Prima di comporre il numero, il modem riaggancia e attende n secondi; n compreso tra 0 e 255. Nota: quando l'opzione ATX2 o ATX4 è attiva, il valore di S6 viene ignorato. Valore predefinito= 2
S7 |  | Time-out chiamata
 | S7=n | Numero di secondi entro i quali è necessario stabilire la connessione oppure la chiamata verrà disconnessa; n è compreso tra 1 e 255. Valore predefinito = 60
S8 |  | Periodo di pausa
 | S8=n | Effettua una sospensione di n secondi; n è compreso tra 0 e 255; per modificatore di composizione in una stringa di composizione. Valore predefinito = 2
S10 |  | Disconnessione da perdita del segnale DCD
 | S10=n | Si disconnette dopo n secondi; nè compreso tra 0 e 255 con incrementi di 0,1 secondi; dopo che il segnale DCD viene disattivato. Valore predefinito = 14
S11 |  | Durata della tonalità
 | S11=n | Specifica la durata, con incrementi di 0,001 secondi, del tono DTMF generato; n compreso tra 60 e 255. Valore predefinito =72
S12 |  | Tempo di controllo del codice di escape
 | S12=n | Specifica l'intervallo, con incrementi di 0,02 secondi, che deve essere presente ad entrambe le estremità del codice di escape (+++) affinché il modem riconosca il comando di escape e passi alla modalità comandi. Se S12=0, la velocità alla quale viene immessa la sequenza di escape non è rilevante. Valore predefinito = 50
S18 |  | Timer del test
 | S18=n | Specifica la durata di esecuzione del test; n è compreso tra 0 e 255. Valore predefinito = 0

Tabella 1: Comandi ATS (S-Register)


Comando di diagnostica AT#UD Unimodem: Software per modem Motorola SM56 - Manuale dell'utente

La specifica relativa al comando di diagnostica Unimodem è fornita da Microsoft in modo tale che il funzionamento dei diversi modem sia coerente durante operazioni di diagnostica delle sessioni di dati. L'ultima revisione della specifica relativa a questo comando è reperibile presso il sito Web di Microsoft.

Sintassi del comando:

AT#UD

#UD è un comando di azione. Non accetta parametri.

Sebbene tale comando debba essere utilizzato al termine della chiamata, è possibile definire i codici affinché il modem possa rispondere prima che la chiamata venga effettuata e durante la chiamata stessa, per attività di monitoraggio in tempo reale.

Risposta al comando:

In risposta al comando, il modem riporta le informazioni relative al modem stesso. Ogni riga di testo ha il formato seguente, comprese una o più coppie di parametri chiave=valore:

DIAG <token chiave = valore [[chiave = valore] [chiave= valore]] …>

Dove token è un numero esadecimale univoco a 32 bit 2A4D3263

chiave è un numero esadecimale, descritto nella colonna 1 della Tabella 1.

valore è una stringa definita nella colonna 2 della Tabella 1.

NOTA: se non diversamente specificato, tutti i valori sono numeri esadecimali.

Chiave | Valore | Definizione
0 | 2 cifre | Numero di revisione delle specifiche del comando di diagnostica
1 | Vedere la Tabella 2 | Codice di risultato impostazione chiamata
2 | Vedere la Tabella 3 | Modalità multimediale
3 | Vedere la Tabella 4 | Modalità interfaccia DTE-DCE
4 | Stringa | Stringa ottetto V.8 CM, stesso formato di V.25ter Annex A, tra virgolette
5 | Stringa | Stringa ottetto V.8 JM, stesso formato di V.25ter Annex A, tra virgolette
6F |  | Riservato ai prospetti di negoziazione chiamata
10 | 0-2F | Livello di potenza del segnale di ricezione, in –dBm (0-43)
11 | 0-1F | Livello di potenza del segnale di trasmissione, in –dBm (ad es. 0-17)
12 | 0-64 | Livello di rumore, in –dBm (ad es. 10-90)
13 | 0-FF | Errore Normalized Mean Squared, 100 (0x64) = distanza minima di intersimbolo
14 | 0-3F | Perdita Near echo, in unità di dB
15 | 0-3F | Perdita Far echo, in unità di dB
16 | 0-3F | Ritardo Far echo, in unità di ms
17 | 0-FFF | Ritardo Round Trip, in unità di ms
18 | Vedere la Tabella 5 | Bitmap V.34 INFO
19-1F |  | Riservato ai prospetti di addestramento e di impostazione della modulazione
20 | Vedere la Tabella 6 | Risultati di negoziazione carrier in trasmissione
21 | Vedere la Tabella 6 | Risultati di negoziazione carrier in ricezione
22 | 0-1F40 | Velocità del simbolo carrier in trasmissione (0-8000) in simbolo/i
23 | 0-1F40 | Velocità del simbolo carrier in ricezione (0-8000) in simbolo/i
24 | 0-FA0 | Frequenza carrier in trasmissione (0-4000) in Hz
25 | 0-FA0 | Frequenza carrier in ricezione (0-4000) in Hz
26 | 0-FA00 | Velocità iniziale dati carrier in trasmissione (0-64000) in bit/s
27 | 0-FA00 | Velocità iniziale dati carrier in ricezione (0-64000) in bit
28-2F |  | Riservato
30 | 0-FF | Conteggio temporaneo evento di perdita carrier
31 | 0-FF | Conteggio evento rinegoziazione della velocità del carrier
32 | 0-FF | Richiesta sincronizzazione carrier
33 | 0-FF | Richieste sincronizzazione carrier soddisfatte
34 | 0-FA00 | Velocità finale dati carrier in trasmissione in bit/s
35 | 0-FA00 | Velocità finale dati carrier in ricezione in bit/s
36-3F |  | Riservato
40 | Vedere la Tabella 7 | Risultati di negoziazione del protocollo
41 | 0-400 | Dimensioni del frame di controllo degli errori in byte
42 | 0-FF | Tempi di attesa del collegamento del controllo errore in trasmissione
43 | 0-FF | Ricevuti NAK di collegamento controllo errore
44 | Vedere la Tabella 8 | Risultato negoziazione della compressione
45 | 0-800 | Dimensione dizionario compressione in byte
46-4F |  | Riservato
50 | 0-2 | Controllo flusso di trasmissione: 0 = non attivo; 1 = DC1/DC3; 2 = V.24 ckt 106/133
51 | 0-2 | Controllo flusso di ricezione: 0 = non attivo; 1 = DC1/DC3; 2 = V.24 ckt 106/133
52 | 0-FFFFFFFF | Caratteri di trasmissione inviati da DTE
53 | 0-FFFFFFFF | Caratteri ricevuti inviati a DTE
54 | 0-FFFF | Caratteri di trasmissione persi (errori di overrun dei dati da DTE)
55 | 0-FFFF | Caratteri di ricezione persi (errori di overrun dei dati da DTE)
56 | 0-FFFFFFFF | Conteggio I- Frame di trasmissione, se il protocollo di controllo degli errori è in esecuzione
57 | 0-FFFFFFFF | Conteggio I- Frame di ricezione, se il protocollo di controllo degli errori è in esecuzione
58 | 0-FFFF | Conteggio degli errori I-Frame di trasmissione, se il protocollo di controllo degli errori è in esecuzione
59 | 0-FFFF | Conteggio degli errori I- Frame di ricezione, se il protocollo di controllo degli errori è in esecuzione
5A-5F |  | Riservato
60 | Vedere la Tabella 9 | Motivo dell'arresto
62-7F |  | Riservato per versioni future della specifica
80-FF |  | Riservato per chiavi proprietarie del produttore

Tabella 1 - Formato del prospetto sullo stato dell'ultima chiamata AT#UD

Codice | Definizione
0 | Nessuna chiamata precedente (il file di registro del modem è stato cancellato dall'ultima chiamata)
1 | Nessun segnale di linea rilevato
2 | Rilevato segnale di riordine, rete occupata
3 | Rilevato segnale di occupato
4 | Nessun segnale riconosciuto rilevato (ad esempio, nessun segnale oppure nessun segnale riconoscibile)
5 | Rilevato segnale di fonia * se si tratta di un modem che supporta la fonia (ad esempio V.253) che opera in modalità di fonia (ad esempio +FCLASS=8.0)
6 | Rilevato segnale telefonico di testo (vedere V.18)
7 | Rilevato segnale di risposta dati (ad esempio V.25 ANS, V.8 ANSam)
8 | Rilevato segnale di chiamata dati (ad esempio V.25 CT, V.8 CI)
9 | Rilevato segnale di risposta fax (ad esempio T.30 CED, DIS)
A | Rilevato segnale di chiamata fax (ad esempio T.30 CNG)
B | Rilevato segnale V.8bis
C-F | Riservato

Tabella 2 - Codici di risultato relativi all'impostazione della chiamata

Codice | Definizione
0 | Solo dati
1 | Solo FAX
2 | Solo fonia * se la modalità di fonia è supportata (ad esempio V.253, IS-101)
3 | VoiceView™
4 | ASVD, V.61
5 | ASVD, “V.34Q”
6 | DSVD, Multi-Tech
7 | DSVD, 1.2
8 | DSVD, V.70
9 | Videotelefonia, H.324
A | Altra chiamata V.80
B-F | Riservato

Tabella 3 – Modalità multimediali

Codice | Definizione
0 | Dati asincroni
1 | Modalità sincrona trasparente V.80
2 | Modalità sincrona con frame V.80
3-F | Riservato

Tabella 4 – Modalità DTE-DCE

Bit | Bit di origine | Definizione
31-30 | INFO0 bit 20; 0 |
20-29 | INFOc bit 79-88 |
16-19 | INFOc bit 26-29 o 35-38 o 44-47 o 53-56 o 62-65 o 71-74 | Campo pre-enfasi, selezionato tramite notazione di velocità scelta
12-15 | INFOa bit 26-29 |
10-11 | MP bit 50; 0 |
0-9 | INFOa bit 40-49 |

Tabella 5 – Prospetto bit V.34 INFO (valido solo per chiamate V.34 o V.90)

Valore | Descrizione
0 | V.17 (chiamata fax G3)
1 | V.21
2 | V.22
3 | V.22bis
4 | V.23 Constant Carrier (1200/75)
5 | V.23 Switched Carrier (half duplex)
6 | V.26bis
7 | V.26ter
8 | V.27ter (chiamata Fax G3)
9 | V.29 HD (chiamata Fax G3)
A | V.32 (difficoltà di distinzione rispetto a V.32bis)
B | V.32bis
C | V.34
D | V.34 HD (chiamata Fax G3)
E | V.90 versione 1 (asimmetrico)
F | V.90 versione 2 (simmetrico)
E-7F | Riservato (V.58)
80 | X2™
81 | K56FLEX™
82 | V.FC
83 | V.32terbo
84 | Bell 212A (se il modem supporta B212A)
85 | Bell 103 (se il modem supporta B103)
80-FF | Riservato per mfgs

Tabella 6 – gstnModulationSchemeActive da 3.7.2/V.58

Valore | Descrizione
0 | Disattivo/nessuno
1 | V.42 LAPM
2 | Protocollo alterativo V.42 (MNP™)
3-7F | Riservato (V.58)
80 | MNP10™
81 | ECP™ (Enhanced Cellular Protocol)
82 | ETC™ (Enhanced Throughput Cellular)
82-FF | Riservato a mfgs

Tabella 7 – errorControl Active da 3.5.2/V.58

Valore | Descrizione
0 | Nessuno
1 | V.42bis
2-7F | Riservato (V.58)
80 | MNP5™
81-FF | Riservato per mfgs

Tabella 8 – compressionActive da 3.2.2/V.58

Indica che il segnale DCE è passato in modalità Hook e che la connessione di rete attiva in precedenza è stata annullata. Questi valori sono esadecimali.

Valore | Descrizione | Note
0 | CauseUnidentified | Problemi di impostazione della chiamata
1 | Nessuna chiamata precedente | Non in V.58
2 | La chiamata è ancora in corso | Non in V.58
3 | Rilevato segnale di attesa di chiamata | Non in V.58, solo se il modem è in grado di rilevarlo
4 | Ritardato | Lo stesso valore di 2A, CallAttemptsLimitExceeded
A | NMSinitiatedDialCall | -- Sistema di gestione di rete
B | NMSinitiatedLeasedLineRestoral |
C | NMSinitiatedRedial |
D | NMSinitiatedDialDisconnect |
14 | PowerLoss | DCE
15 | EquipmentFailure |
16 | FrontPanelDisconnectRequested | Se c'è un pannello frontale associato a questo controllo
17 | FrontPanelLeasedLineRestoral |
18 | AutomaticLeasedLineRestoral |
19 | InactivityTimerExpired |
1E | cct116RestoralRequest | Interfaccia DTE
1F | cct108isOffInhibitsDial |
20 | cct108turnedOff | Blocco con &D2
28 | NoNumberProvided | Non consentito da alcune normative nazionali
29 | BlacklistedNumber |
2A | CallAttemptsLimitExceeded | Come per “Ritardato”, vedere ETS 300 001
2B | ExtensionPhoneOffHook | Se il rilevamento di interno è supportato
2C | CallSetupFailTimerExpired | ad esempio S7 timeout
2D | IncomingCallDetected | Se viene rilevata una chiamata in entrata durante l'invio di un comando di composizione.
2E | LoopCurrentInterrupted |
2F | NoDialTone |
30 | VoiceDetected |
31 | ReorderTone |
32 | SitTone |
33 | EngagedTone |
34 | LongSpaceDisconnect | Quando il programma del modem deve essere interrotto su spazio lungo
3C | CarrierLost | Convertitore di segnale
3D | TrainingFailed |
3E | NoModulationinCommon |
3F | RetrainFailed |
40 | RetrainAttemptCountExceeded |
41 | GstnCleardownReceived |
42 | FaxDetected |
46 | InTestMode | Test
47 | IntrusiveSelfTestInitiated |
50 | AnyKeyAbort | Controllo di chiamata
51 | DteHangupCommand | Se il comando ATH è stato utilizzato per terminare la chiamata precedente.
52 | DteResetCommand | Se ATZ è stato utilizzato per terminare la chiamata precedente.
5A | FrameReject | Controllo di errore
5B | NoErrorControlEstablished | Richiesta del controllo di errore
5C | ProtocolViolation |
5D | n400exceeded |
5E | NegotiationFailed |
5F | DisconnectFrameReceived |
60 | SabmeFrameReceived |
64 | LossOfSynchronization | Compressione dati

Tabella 9 – Codici callCleared da 3.6.4/V.58-1994

Esempi di utilizzo e di risposte del modem

Risposta del modem | Descrizione
DIAG <2A4D3263 0=10 | Versione 1.0
DIAG <2A4D3263 1=06 2=0 3=0> | Rilevato segnale di risposta dati; solo dati; asincronia caratteri
DIAG <2A4D3263 5=”C14513902A” 6=”A145” | Il menu di chiamata V.8 indica: Il menu di unione V.8 consente di selezionare:
DIAG <2A4D3263 10=1F 11=0C 12=52> | Livello di ricezione = -31dbm; livello di trasmissione = -12dbm; livello di rumore = -82dbm
DIAG <2A4D3263 14=03 15=05 16=10> | Ritardo far end echo in millesimi di secondo; perdita far end echo in dB; Perdita near end echo = 16 dB
DIAG <2A4D3263 20=C 22=780 24=0C80 26=79E0 > | Trasmettitore: sincronizzazione iniziale V.34 completata; frequenza carrier V.34 = 1920; notazione di velocità V.34 = 3200; velocità di trasmissione iniziale pari a 31200 bit/s
DIAG <2A4D3263 21=D 25=1F40 27=DAC0 > | Ricevitore: sincronizzazione iniziale V.90 completata; notazione di velocità V.90 = 8000; velocità di ricezione iniziale pari a 56000 bit/s
DIAG <2A4D3263 30=00 31=03 32=01 33=01> | Nessun evento di perdita carrier, 3 tentativi di rinegoziazione di velocità carrier; 1 richiesta di sincronizzazione carrier; 1 sincronizzazione carrier concesso
DIAG <2A4D3263 34=7080 35=CB20> | Velocità di trasmissione iniziale pari a 28.800 bit/s; velocità di ricezione finale pari a 52000 bit/s
DIAG <2A4D3263 40=1 41=100> | Negoziazione LAPM completata; dimensioni frame = 256
DIAG <2A4D3263 42=0 43=0> | Nessun timeout di controllo degli errori o NAK di collegamento
DIAG <2A4D3263 44=1 45=400> | Compressione dati V.42bis utilizzata; dimensioni dizionario = 1024
DIAG <2A4D3263 50=2 51=2> | Controllo di flusso di ricezione e trasmissione hardware
DIAG <2A4D3263 52=343CC 54=0> | 213964 caratteri DTE trasmessi, senza underrun
DIAG <2A4D3263 53=7230E6 55=47> | 7483622 DTE caratteri ricevuti, 71 caratteri persi a causa di overrun in ricezione dati
DIAG <2A4D3263 56=29D 58=0001> | 597 frame (decimali) trasmessi, con 1 errore frame
DIAG <2A4D3263 58=2A4B 59=0004> | 10827 frame (decimali) ricevuti, con 4 errori frame
DIAG <2A4D3263 60=51> | Disconnessione iniziata dal PC locale

Tabella 10 - Chiamata dati completata, con errori e risincronizzazione di velocità durante la chiamata


Identificazione chiamata (solo negli Stati Uniti e nel Canada): Software per modem Motorola SM56 - Manuale dell'utente

NOTA: Questa funzione non è disponibile nei modem dati/fax.

Il modem può rilevare le informazioni generate dalla funzione del servizio Identificazione chiamata, offerto da diverse compagnie telefoniche. Ottenere ulteriori informazioni dalla propria compagnia telefonica.

Con Identificazione chiamata, le informazioni relative al numero della persona che chiama e la data e ora della chiamata sono trasmesse tramite linea telefonica tra il primo e il secondo squillo. In alcune zone, sono disponibili ulteriori dati come ad esempio il nome della persona che chiama, con il servizio Identificazione chiamata avanzato.

Il modem trasferisce i dati del servizio Identificazione chiamata all'applicazione di comunicazione. È possibile configurare l'applicazione per elaborare o tenere traccia dei dati.

Se si è abbonati al servizio Identificazione chiamata e il servizio non opera in maniera corretta, consultare la sezione Risoluzione dei problemi.

La persona che chiama può impedire la trasmissione delle informazioni del servizio Identificazione chiamata.


CTS: Software per modem Motorola SM56 - Manuale dell'utente

Alla pagina dell'indice

CTS: CTS: Software per modem Motorola SM56 - Manuale dell'utente

Segnale Clear to Send (CTS). Il modem invia questo segnale al computer locale quando è pronto a ricevere dati dal computer stesso.

Rappresenta un metodo più efficiente per la trasmissione dei dati.

Leggere attentamente le restrizioni e le esclusioni di responsabilità.


DC: Software per modem Motorola SM56 - Manuale dell'utente

Segnale DC (Data Compression). Compressione dei dati.


DCD: Software per modem Motorola SM56 - Manuale dell'utente

Segnale Data Carrier Detect (DCD). Il modem invia questo segnale al computer locale non appena riceve un segnale di portante accettabile sulla linea telefonica. Se tale segnale viene perduto, il modem lo invia nuovamente.

Leggere attentamente le restrizioni e le esclusioni di responsabilità.


Determinare il tipo di modem: Software per modem Motorola SM56 - Manuale dell'utente

Alla pagina dell'indice

Determinazione del tipo di modem: Software per modem Motorola SM56 - Manuale dell'utente

Sono disponibili tre diversi tipi di modem SM56 e ciascuno supporta diversi tipi di funzioni. È possibile stabilire il tipo di modem di cui si dispone aprendo l'applicazione in Pannello di controllo e facendo doppio clic sull'icona Modem. Nella finestra principale dell'applicazione verrà visualizzato il nome prodotto del modem installato. Nella tabella riportata di seguito, il nome prodotto viene riportato nella colonna 1, il tipo di modem installato viene riportato nella colonna 2 mentre le caratteristiche relative a ciascun tipo di modem sono riportate nella colonna 3.

Nome prodotto | Tipo di modem | Caratteristiche
Motorola SM56 PCI Fax Modem Motorola SM56 AC-L Modem Motorola SM56 AC-L(s) Modem Motorola SM56 AC-L(v) Modem | solo dati/fax | • Modalità dati e fax • Nessuna segreteria telefonica (TAM) • Nessuna identificazione chiamata • Nessuna funzione di squillo distinto • Nessuna funzione di vivavoce
Motorola SM56 PCI Voice Modem Motorola SM56 AC-L(s) Voice Modem Motorola SM56 AC-L(v) Voice Modem | dati/fax/TAM | • Modalità dati e fax • Segreteria telefonica (TAM) • Identificazione chiamata • Funzione di squillo distinto • Nessuna funzione di vivavoce
Motorola SM56 PCI Speakerphone Modem Motorola SM56 AC-L(s) Speakerphone Modem Motorola SM56 AC-L(v) Speakerphone Modem | dati/fax/TAM/vivavoce | • Modalità dati e fax • Segreteria telefonica (TAM) • Identificazione chiamata • Funzione di squillo distinto • Vivavoce full-duplex


Test di diagnostica: Software per modem Motorola SM56 - Manuale dell'utente

Se si verifica un problema di comunicazione, eseguire un rapido test per determinare se il modem risponde ai comandi inviati dal computer. Attenersi alla procedura descritta di seguito.

1. Sulla barra delle applicazioni di Windows, selezionare Start, Impostazioni, Pannello di controllo, quindi l'icona Modem.

2. Selezionare la scheda Diagnostica.

3. Selezionare la porta associata al modem.

4. Selezionare Informazioni.... Il test consiste nell'inviare al modem alcuni comandi AT. La risposta del modem ai comandi dovrebbe essere visualizzata sullo schermo. Altrimenti, chiudere tutte le applicazioni attive e riavviare il computer. Se il problema persiste, proseguire con il test LAL descritto di seguito.

Per ulteriori informazioni, è possibile eseguire un test LAL (Local Analog Loopback) che consente di verificare se i dati trasmessi da e verso il computer locale siano senza errori.

Per eseguire un test LAL:

1. Rimuovere il connettore della linea telefonica dal connettore di input del modem.

2. Avviare un'applicazione di comunicazione che includa la modalità di emulazione terminale. Per esempio, l'applicazione HyperTerminal, presente su qualsiasi computer sul quale è installato Windows, include tale modalità.

3. Inviare il comando AT&F per impostare il modem con le opzioni predefinite del produttore. Verrà visualizzato il messaggio OK.

4. Inviare il comando ATS46=23.

5. Inviare il comando AT&T1 (i caratteri potrebbero non apparire durante la digitazione). Attendere 10 secondi.

6. Digitare alcuni caratteri con la tastiera. Questi dovrebbero venire visualizzati sullo schermo.

7. Digitare +++. Verra visualizzato OK.

8. Digitare il comando ATH (riagganciare) per terminare il test LAL.

Se i caratteri digitati non vengono visualizzati correttamente, chiudere tutte le applicazioni in esecuzione e riavviare il computer. Se il problema persiste, notificare il problema al rivenditore del computer o del modem.


Modificatori di composizione: Software per modem Motorola SM56 - Manuale dell'utente

Il modem supporta i seguenti caratteri di modifica della composizione. I modificatori sono utilizzati all'interno di una stringa di composizione per consentire al modem di gestire situazioni quali l'utilizzo di una carta telefonica, l'accesso a linee esterne relative ad un sistema PBX e l'utilizzo della composizione a impulsi.

Carattere | Nome | Funzione
@ | Risposta silenziosa | Attende uno o più squilli, quindi cinque secondi di silenzio, prima di continuare con la stringa di composizione
H | Disconnessione | Si disconnette dalla linea telefonica.
K k , < | Periodo di pausa | Sospensione; il tempo predefinito è tre secondi
P | Composizione a impulsi | Utilizza la modalità di composizione a impulsi
R | Inversione | Passa in modalità di risposta subito dopo la composizione; da utilizzare quando il modem remoto può solo originare chiamate
T | Composizione a frequenza | Utilizza la modalità di composizione a frequenza
W w | Attesa di composizione | Resta in pausa fino al rilevamento di una tonalità di chiamata
; | Modalità comandi | Torna alla modalità comandi dopo la composizione, senza interrompere la connessione corrente. Consente di trasmettere cifre sotto forma di tonalità.
!& | Flash | Aggancio rapido. Abilita le caratteristiche di composizione PBX.


Stringa di composizione: Software per modem Motorola SM56 - Manuale dell'utente

Una serie di caratteri che specificano il numero da comporre e le azioni che il modem deve eseguire durante la composizione.

Composta da cifre e caratteri speciali.


Squillo distinto (solo negli Stati Uniti): Software per modem Motorola SM56 - Manuale dell'utente

NOTA: Questa funzione non è disponibile nei modem dati/fax.

Il modem può identificare i tipi di chiamata generati dalla funzione del servizio Squillo distinto, offerto da diverse compagnie telefoniche. Ottenere ulteriori informazioni dalla propria compagnia telefonica.

Con il servizio Squillo distinto, vengono assegnati diversi numeri telefonici alla linea telefonica dell'utente. Ciascun numero, quando chiamato, genera un tipo diverso di squillo. Ciò consente di utilizzare un'unica linea telefonica per tutti i tipi di chiamata; voce, dati e fax.

Il modem trasferisce i dati di Squillo distinto all'applicazione di comunicazione. Quindi, il modem può instradare le chiamate all'applicazione appropriata. Ad esempio, quando viene composto il numero del fax, il modem attiva l'applicazione del fax.

Alla pagina dell'indice

Distinctive Ring (US only)


Codici e motivi di disconnessione: Software per modem Motorola SM56 - Manuale dell'utente

Quando il modem si disconnette dalla linea telefonica, viene generato e salvato un messaggio che indica il motivo della disconnessione. Per visualizzare il messaggio relativo alla disconnessione più recente, inviare il comando ATI5 usando il proprio programma di comunicazione. Verrà visualizzato uno dei seguenti messaggi.

Messaggio indicante la ragione della disconnessione

Inglese:

Nessuno

DTR DROP

ATH RECEIVED

REMOTE DISCONNECT

OFF-LINE TEST

TRAINING FAILURE

EC LOCAL REQUEST

ALREADY CONNECTED

DIAL ABORTED

BUSY TONE DETECTED

NO DIALTONE

DIAL ABORTED - INCOMING CALL

IMPROPER DTR STATE

PHONE NUMBER BLACKLISTED

RETRAIN THRESHOLD

SEMICOLON DETECTED

ABT TIMEOUT - NO RINGBACK

ABT TIMEOUT - RING BACK RECEIVED

ABT TIMEOUT - NO CALL PROGRESS

ABT TIMEOUT - NO ANSWER

BUSY AFTER RING BACK

EC - TRANSMISSION LIMIT

EC - REMOTE REQUESTED

EC - NO VALID PACKET RECEIVED

EC - ESTABLISHMENT ERROR

EC - ACCEPTOR TIMEOUT

EC - NEGOTIATION FAILURE

EC - PROTOCOL VIOLATION

EC - BAD PARAMETER

EC - DATA COMPRESSION ERROR

FSK RELIABLE INVALID

DTE INACTIVITY TIMEOUT

EC REMOTE NO PSTN

RETRAIN TIMEOUT

VOICE DISCONNECT - VLS = 0

VOICE TO FAX/DATA SWITCH

UNKNOWN

Tabella 1: Codici e motivi di disconnessione

<


Supporto per applicazioni MS-DOS: Software per modem Motorola SM56 - Manuale dell'utente

Il modem SM56 supporta le applicazioni eseguite dal prompt dei comandi nella finestra DOS di Windows 98.

Per attivare il supporto per la finestra DOS, fare doppio clic sull'icona Modem in Windows e selezionare la casella Enable DOS. Non è necessario riavviare Windows.

Durante la configurazione delle applicazioni MS-DOS per la comunicazione con il modem, utilizzare l'IRQ standard e le informazioni I/O di base per il numero della porta COM. Gli IRQ standard e gli I/O di base sono i seguenti:

I/O di base IRQ porta COM

COM1 4 3F8

COM2 3 2F8

COM3 4 3E8

COM4 3 2E8

Il modem utilizza due IRQ per il supporto delle applicazioni MS-DOS:

• L'IRQ DOS standard (vedi sopra)

• L'IRQ indicato nella scheda Risorse della finestra delle proprietà del modem (Pannello di controllo, icona Sistema, scheda Gestione periferiche)

Assicurarsi che vengano assegnati IRQ diversi durante l'installazione delle applicazioni MS-DOS. Se necessario, modificare l'IRQ del modem, selezionando il pulsante Modifica impostazioni nella scheda Risorse del modem.


Giochi e applicazioni MS-DOS: Software per modem Motorola SM56 - Manuale dell'utente

Stringhe di comando

È possibile utilizzare il modem con giochi e altre applicazioni per MS-DOS. La maggior parte di essi prevedono la possibilità di aggiungere modem non supportati al proprio elenco di modem. Altri consentono di inserire le informazioni relative al modem da utilizzare. Le informazioni che possono essere necessarie a tali applicazioni sono le seguenti.

• Stringa di inizializzazione - per l'impostazione del modem in una modalità conosciuta

• Stringa di disconnessione - per terminare una chiamata

• Stringa di composizione - per richiedere al modem di avviare una chiamata

• Stringa di risposta - per richiedere al modem di rispondere a una chiamata

• Velocità della porta COM - per inviare i dati serializzati al modem

Stringhe di comando

È possibile usare le seguenti stringhe di comando con il modem.

Inizializzazione: AT&F

Inizializzazione con giochi che richiedono al modem di non eseguire funzioni di correzione degli errori e di compressione dei dati: ATS46=23 AT&F\N0

• Disconnessione: ATH0

• Stringa di composizione: ATDT

• Stringa di risposta: ATA

• Velocità della porta COM: 115,200

NOTA: non inserire spazi tra i comandi.

Per ulteriori informazioni sull'attivazione del supporto per MS-DOS di Windows 98, vedere Supporto di applicazioni MS-DOS.


DSR: Software per modem Motorola SM56 - Manuale dell'utente

Segnale DSR (Data Set Ready). Il modem invia questo segnale al computer quando è pronto per la fase di trasmissione dati.

Leggere attentamente le restrizioni e le esclusioni di responsabilità.


Frequenza DTMF (Dual Tone Multi-Frequency): Software per modem Motorola SM56 - Manuale dell'utente

Metodo utilizzato dal sistema di telefonia per comunicare i tasti relativi ai numeri selezionati.

Leggere attentamente le restrizioni e le esclusioni di responsabilità.


DTR: Software per modem Motorola SM56 - Manuale dell'utente

Segnale DTR (Data Terminal Ready). Il computer invia questo segnale al modem quando è pronto per accettare i dati trasmessi.


Parola di rapporto degli eventi: Software per modem Motorola SM56 - Manuale dell'utente

Alla pagina dell'indice

Parola di prospetto degli eventi: Software per modem Motorola SM56 - Manuale dell'utente

È possibile usare il comando AT+VEM per definire eventi da relazionare. L'elenco è codificato sotto forma di parola composta dai bit di seguito riportati.

NOTA: Tutti gli eventi vengono attivati per valore predefinito e indicati dal numero di bit sottolineato.

Un 1 in una posizione di bit indica che si rappporta un evento.

Uno 0 in una posizione di bit indica che non si rappporta un evento.

Lettura dei bit da destra (bit 0) a sinistra (bit 32).

Le celle vuote nella tabella indicano gli eventi non supportati.

Bit | Segnale
0 | Identificazione della chiamata (effettiva solo dove la funzione è supportata dal gestore telefonico. Non è supportata nei modem dati/fax).
1 |
2 | Squillo distinto (operativo solo quando la funzione è supportata)
3 | RING (squillo)
4 | Rilevazione DTMF
5 | Superamento della capacità del buffer di ricezione
6 | Chiamata fax
7 | Chiamata dati
8 |
9 | Superamento del tempo di scollegamento presunto (SILENCE)
10 | Superamento del tempo di fine messaggio presunto (QUIET)
11 |
12 |
13 |
14 |
15 |
16 |
17 |
18 | Ring Back
19 | BUSY (occupato)
20 | DIALTONE (segnale di linea)
21 |
22 |
23 | Sottoutilizzo del buffer di riproduzione
24 |
25 | Rilevazione di fax o di modem di risposta dati
26 |
27 | Rilevazione della voce
28 |
29 |
30 |
31 |
32 |


EC: Software per modem Motorola SM56 - Manuale dell'utente

EC (Error Correction). Correzione degli errori.


Fax Service Class 1: Software per modem Motorola SM56 - Manuale dell'utente

Il modem supporta lo standard Group 3 Facsimile Service Class 1, come definito nelle specifiche tecniche. Se si dispone di un software per la gestione dei fax, è possibile utilizzare il computer e il modem per inviare e ricevere fax. In caso di difficoltà nell'invio o nella ricezione di fax, consultare la sezione relativa ai comandi AT+ che controllano le operazioni fax.


Sommario: Software per modem Motorola SM56 - Manuale dell'utente

Software per modem Motorola SM56 - Manuale dell'utente

Introduzione
Determinazione del tipo di modem
V.90/V.92 e K56flex
Supporto tecnico
Connettori telefonici
Installazione o reinstallazione del modem
Disinstallazione e aggiornamento del modem SM56
Compatibilità
Supporto per applicazioni MS-DOS
Giochi e applicazioni MS-DOS
Fax Service Class 1
Identificazione chiamata
Squillo distinto
Modificatori di composizione
Codici di risultato e messaggi di connessione
Comandi AT – Nozioni fondamentali
Comandi +++ (più-più-più)
Comandi AT e AT&
Comandi AT% (percentuale) e AT\ (barra rovesciata)
Comandi AT* (asterisco)
Comandi AT+ (più)
Comandi ATS (S-Register)
Comando di diagnostica AT#UD Unimodem
Parola di rapporto degli eventi
Risoluzione dei problemi
Codici e motivi di disconnessione
Test di diagnostica
Disinstallazione del modem
Aggiunta di comandi AT

Le informazioni del presente documento sono soggette a modifica senza preavviso.
© 2002 Motorola. Tutti i diritti riservati.

Marchi e nomi commerciali sono stati utilizzati all'interno del presente documento come riferimento ai rispettivi proprietari dei marchi, dei nomi oppure dei relativi prodotti. Motorola dichiara di non avere alcun interesse poprietario rispetto ai marchi e ai nomi commerciali diversi dai propri.


Installazione o reinstallazione del modem: Software per modem Motorola SM56 - Manuale dell'utente

Requisiti • Installazione del modem: hardware • Installazione del modem: software • Installazione per Windows 98, Windows 2000 e Windows XP • Windows Millennium • Windows NT 4.0 • Recupero di un'installazione interrotta o annullata

Generalmente, il modem SM56 è preinstallato sul computer, ma è comunque possibile reinstallarlo.

ATTENZIONE: utilizzare solo una scheda sul computer.

Requisiti

Il modem deve essere installato su un personal computer dotato dei componenti riportati di seguito:

• sistema operativo: Windows 98, Windows Millenium, Windows NT 4.0, Windows 2000 e Windows XP;

• una tra le seguenti configurazioni processore/memoria cache:

- CPU Pentium® 150 MHz o superiore (consigliato 200 MHz per operazioni V.90)

- CPU AMD K6® 233 MHz o superiore con 256K di memoria cache L2

- CPU Cyrix® MII 266 MHz o superiore con 256K di memoria cache L2

- CPU Intel® Celeron 266 MHz o superiore

• 8 MB di spazio libero su disco rigido;

• 16 MB RAM - per Windows 98 o Windows Millenium;

• 32 MB RAM - per Windows 2000, Windows NT 4.0, Windows XP.

Requisiti necessari per il modem SM56:

• un'alloggiamento a 32 bit disponibile o un alloggiamento AC-Link (per SM56 AC-L);

• un IRQ disponibile: da 3 a 15 per modem PCI.

Per modem dati/fax/vivavoce e dati/fax/TAM è necessaria una scheda audio compatibile.

Installazione del modem

Parte 1: installazione dell'hardware

Procedere all'installazione del modem nel modo seguente:

1. Stampare questo argomento della Guida in linea per poter consultare la copia su carta.

2. Spegnere il computer e disconnettere il cavo di alimentazione.

3. Aprire il computer e inserire la scheda modem in un alloggiamento PCI o AC-Link.

4. Collegare il modem a una presa telefonica analogica utilizzando un cavo telefonico.

5. Accendere il computer.

Parte 2: installazione del software

NOTA: la funzione Plug and Play di Windows assegna al modem un numero di porta COM. Per poter supportare le applicazioni software e giochi MS-DOS in Windows 9x, il software di installazione del modem SM56 tenta di negoziare un numero di porta COM compreso tra 1 e 4.

Installazione per Windows 98, Windows Millennium, Windows 2000 e Windows XP

NOTA: la procedura guidata di installazione può presentare leggere differenze nell'ambito delle varie versioni dei sistemi operativi e dei diversi service pack.

Al primo avvio di Windows dopo l'installazione della scheda modem SM56, Configuration Manager di Windows rileva la presenza del nuovo hardware, assegna le risorse necessarie, quindi richiede i driver del modem. Configuration Manager ricerca il file di informazioni (INF) contenente le seguenti informazioni sul modem:

• tipo di periferica (modem);

• informazioni sui driver della periferica (il nome del driver che controllerà il modem);

• impostazioni relative ai comandi e alle risposte AT.

Per installare il software, seguire le istruzioni riportate di seguito:

• All'apertura della finestra di dialogo, selezionare Driver su disco fornito dal produttore hardware (oppure Disco driver, a seconda della versione del sistema operativo) e sfogliare le cartelle per individuare il percorso dei driver del modem. Windows dovrebbe reperire le informazioni sul disco e identificare la periferica come modem SM56, copiando quindi i file dal disco di installazione sul computer. A questo punto, l'installazione è terminata.

• Nei modem dati/fax/TAM e dati/fax/vivavoce, dopo l'installazione del modem viene rilevata un'altra periferica. Windows informa di aver rilevato una periferica Serial Wave e richiede l'installazione dei driver per periferiche Wave. Specificare il percorso ai driver SM56 e fare clic su OK.

Una volta installate le due periferiche, viene avviato il programma di installazione del modem SM56.

Il programma di installazione del modem non richiede l'intervento dell'utente durante l'installazione. Esso rileva automaticamente le opzioni relative al Paese e alla lingua di installazione del sistema operativo e le utilizza come valori predefiniti per l'installazione. Eventuali aggiornamenti da una precedente versione dei driver non modificano tali impostazioni.

Installazione per Windows NT 4.0

Importante: | nel software SM56 per Windows NT 4.0 sono disponibili solo le funzioni dati/fax. Vivavoce e TAM non sono supportati.
Importante: | Accertarsi di avere i driver per modem NT 4.0. Essi sono diversi da quelli per Windows 9x, XP o Windows 2000.

Windows NT 4.0 non supporta completamente il plug and play (PnP). Pertanto, dopo l'installazione della scheda modem e dopo aver riavviato il computer, il sistema operativo non riconoscerà il nuovo hardware in maniera automatica. Il modem dovrà quindi essere installato manualmente eseguendo sm56set.exe dal media di distribuzione. Questo programma di installazione aggiungerà automaticamente una nuova porta COM, installerà il modem e lo assegnerà alla nuova porta COM. Una volta completata l'installazione, verrà visualizzato il messaggio di richiesta di riavvio del PC. Bisogna riavviare il PC prima di utilizzare il modem.

Importante:

non è disponibile alcuna applicazione di aggiornamento per Windows 4.0. Per l'aggiornamento a una nuova versione del modem, bisogna prima disinstallare la versione precedente (eseguire il programma di disinstallazione da Aggiungi/Rimuovi Programmi nel Pannello di controllo), quindi eseguire la nuova installazione come descritto nel paragrafo precedente.

Recupero di un'istallazione interrotta o annullata

Durante l'installazione del software del modem, Windows visualizza una finestra di messaggio in cui l'utente può selezionare il pulsante Annulla (o Interrompi). Se tale pulsante viene selezionato mentre l'installazione del software del modem è in corso, l'installazione sarà solo parziale. Un'installazione parziale non offre garanzie di corretto funzionamento.

Per "ripulire" il sistema in modo completo è necessario:

1. Aprire il Pannello di controllo.

2. Selezionare Installazione applicazioni.

3. Selezionare il modem SM56.

4. Fare clic su Rimuovi.

5. Riavviare il computer.

Al riavvio, la funzione Plug and Play di Windows rileverà nuovamente il modem. A questo punto, indicare alla procedura guidata la cartella in cui sono contenuti i driver per il modem ed eseguire l'installazione in modo completo. Il modem funzionerà correttamente.


Codici di risultato e messaggi di connessione: Software per modem Motorola SM56 - Manuale dell'utente

Il modem invia al computer messaggi indicanti lo stato della connessione. L'applicazione di comunicazione utilizza queste informazioni per tenere sotto controllo l'andamento della connessione e intraprendere le azioni appropriate.

Il contenuto e il formato del messaggio sono determinati da:

• L'opzione del parametro relativo alla visualizzazone del codice di risultato (ATQ ), che attiva la visualizzazione dei codici di risultato.

• L'opzione del parametro relativo al formato del codice di risultato (ATV ), che determina il formato del messaggio di risultato (messaggi di testo in formato esteso o codici numerici in formato breve).

• L'opzione del parametro relativo al reporting sullo stato della chiamata (ATX ), che determina i tipi di messaggio visualizzati.

• L'opzione del parametro relativo al messaggio di connessione (AT\V ), che determina il tipo di informazioni visualizzate all'interno di un messaggio di connessione.

È necessario che il parametro di visualizzazione del codice del risultato sia attivo (ATQ=1) perché il modem possa generare qualsiasi messaggio.

I codici numerici o i messaggi di testo che seguono vengono inviati in conformità all'opzione di reporting sullo stato della chiamata (ATX). I messaggi di connessione visualizzati di seguito possono essere generati quando il parametro relativo al messaggio di connessione (AT\V) è impostato sull'opzione di sola velocità (AT\V0 o AT\V2).

Codice | Messaggio di testo | Opzione di reporting sullo stato della chiamata (ATX)
0 | OK | 0,1,2,3 o 4
1 | CONNECT 75 (connessione) | 0
NOTA: se lo stato della chiamata è 0, la ricezione del codice numerico 1 indica solo che una connessione è stata effettuata. Se lo stato della chiamata è 1, 2, 3 o 4, la ricezione di un codice numerico 1 indica che è stata effettuata una connessione a 75 bps.
2 | RING (squillo) | 0, 1, 2, 3 o 4
3 | NO CARRIER (segnale portante assente) | 0, 1, 2, 3 o 4
4 | ERROR (errore) | 0, 1, 2, 3 o 4
5 | CONNECT 1200 (connessione a 1200) | 1, 2, 3 o 4
6 | NO DIALTONE (assenza di segnale di linea) | 2 o 4
7 | BUSY (occupato) | 3 o 4
8 | NO ANSWER (nessuna risposta) | 0, 1, 2, 3 o 4
10 | CONNECT 2400 (connessione a 2400) | 1, 2, 3 o 4
11 | CONNECT 4800 (connessione a 4800) | 1, 2, 3 o
12 | CONNECT 9600 (connessione a 9600) | 1, 2, 3 o 4
13 | CONNECT 600 (connessione a 600) | 1, 2, 3 o 4
20 | CONNECT 300 (connessione a 300) | 1, 2, 3 o 4
22 | CONNECT 7200 (connessione a 7200) | 1, 2, 3 o 4
23 | CONNECT 12000 (connessione a 12000) | 1, 2, 3 o 4
24 | CONNECT 14400 (connessione a 14400) | 1, 2, 3 o 4
25 | CONNECT 16800 (connessione a 16800) | 1, 2, 3 o 4
26 | CONNECT 19200 (connessione a 19200) | 1, 2, 3 o 4
27 | CONNECT 21600 (connessione a 21600) | 1, 2, 3 o 4
28 | CONNECT 24000 (connessione a 24000) | 1, 2, 3 o 4
29 | CONNECT 26400 (connessione a 26400) | 1, 2, 3 o 4
30 | CONNECT 28800 (connessione a 28800) | 1, 2, 3 o 4
31 | CONNECT 31200 (connessione a 31200) | 1, 2, 3 o 4
32 | CONNECT 33600 (connessione a 33600) | 1, 2, 3 o 4
34 | CONNECT 38400 (connessione a 38400) | 1, 2, 3 o 4
35 | CONNECT 57600 (connessione a 57600) | 1, 2, 3 o 4
36 | CONNECT 115200 (connessione a 115200) | 1, 2, 3 o 4
37 | CONNECT 32000 (connessione a 32000) | 1, 2, 3 o 4
38 | CONNECT 34000 (connessione a 34000) | 1, 2, 3 o 4
39 | CONNECT 36000 (connessione a 36000) | 1, 2, 3 o 4
40 | CONNECT 38000 (connessione a 38000) | 1, 2, 3 o 4
41 | CONNECT 40000 (connessione a 40000) | 1, 2, 3 o 4
42 | CONNECT 42000 (connessione a 42000) | 1, 2, 3 o 4
44 | CONNECT 44000 (connessione a 44000) | 1, 2, 3 o 4
46 | CONNECT 46000 (connessione a 46000) | 1, 2, 3 o 4
48 | CONNECT 48000 (connessione a 48000) | 1, 2, 3 o 4
50 | CONNECT 50000 (connessione a 50000) | 1, 2, 3 o 4
52 | CONNECT 52000 (connessione a 52000) | 1, 2, 3 o 4
54 | CONNECT 54000 (connessione a 54000) | 1, 2, 3 o 4
56 | CONNECT 56000 (connessione a 56000) | 1, 2, 3 o 4
58 | CONNECT 58000 (connessione a 58000) | 1, 2, 3 o 4
60 | CONNECT 60000 (connessione a 60000) | 1, 2, 3 o 4
61 | CONNECT 28000 (connessione a 28000) | 1, 2, 3 o 4
62 | CONNECT 29333 (connessione a 29333) | 1, 2, 3 o 4
63 | CONNECT 30666 (connessione a 30666) | 1, 2, 3 o 4
64 | CONNECT 33333 (connessione a 33333) | 1, 2, 3 o 4
65 | CONNECT 34666 (connessione a 34666) | 1, 2, 3 o 4
66 | CONNECT 37333 (connessione a 37333) | 1, 2, 3 o 4
67 | CONNECT 38666 (connessione a 38666) | 1, 2, 3 o 4
68 | CONNECT 41333 (connessione a 41333) | 1, 2, 3 o 4
69 | CONNECT 42666 (connessione a 42666) | 1, 2, 3 o 4
70 | CONNECT 45333 (connessione a 45333) | 1, 2, 3 o 4
71 | CONNECT 46666 (connessione a 46666) | 1, 2, 3 o 4
72 | CONNECT 49333 (connessione a 49333) | 1, 2, 3 o 4
73 | CONNECT 50666 (connessione a 50666) | 1, 2, 3 o 4
74 | CONNECT 53333 (connessione a 53333) | 1, 2, 3 o 4
75 | CONNECT 54666 (connessione a 54666) | 1, 2, 3 o 4

NOTA: le velocità sono espresse in bit/secondo

Tabella 1: Codici di risultato

È anche possibile configurare il messaggio di connessione perché indichi informazioni quali:

• la modalità di modulazione del modem;

• il tipo di correzione errori e il metodo di compressione dati utilizzato per una connessione.

Quando il parametro relativo al reporting sullo stato della chiamata (ATX) è impostato su un valore diverso da zero, i tipi di messaggio di connessione che è possibile inviare in base alla relativa opzione (AT\V) sono quelli che seguono. Non esistono codici numerici corrispondenti a tali messaggi.

Opzione relativa al messaggio di connessione (AT\V)

Messaggio di testo

1

CONNECT rxrate

CONNECT rxrate/ec

CONNECT rxrate/ec/dc

3

CONNECT rxrate

CONNECT rxrate/ec

CONNECT rxrate/ec/dc

4

CONNECT rxrate/mode

CONNECT rxrate/mode/ec

CONNECT rxrate/mode/ec/dc

CONNECT rxrate/txrate/mode

CONNECT rxrate/txrate/mode/ec

CONNECT rxrate/txrate/mode/ec/dc

Dove rxrate = velocità di ricezione dati espressa in bit al secondo

Dove txrate = velocità di trasmissione dati espressa in bit al secondo

Dove dc = uno tra V42BIS, MNP5, V44

Dove mode = una tra V34, V32BIS, V32, V23, V22BIS, V21, K56flex™ , V.90, V.92, B212, B103

Quando AT\V è impostato su 0 o 1, il messaggio di connessione indica la velocità di comunicazione tra computer e modem, cioè la velocità DTE.

Quando AT\V = 2, 3 o 4, il messaggio di connessione indica la velocità di comunicazione tra il modem e il modem remoto, cioè la velocità DCE. Una connessione asimmetrica si verifica quando la velocità di ricezione è diversa dalla velocità di trasmissione. In questo caso, viene visualizzata la velocità di ricezione (seguita dalla velocità di trasmissione, se AT\V = 4).

Tabella 2: Messaggi di connessione

Esempio: Altri messaggi di connessione

Quando le opzioni corrispondenti sono attivate, il modem può generare i seguenti messaggi.

Opzione attivata | Messaggio generato dal modem | Esempio
+ILRR | +ILRR: <velocità>[,<rx_rate>] | +ILRR: 19200
+MR | +MCR: <carrier> +MRR: <velocità>[,<rx_rate>] NOTA: <carrier> i valori sono gli stessi del primo parametro del comando AT+MS. | +MCR: V32B +MRR: 33600
AT+ER | +ER:NONE +ER:LAPM +ER:ALT |
T+DR | +DR:NONE +DR:V42B +DR:V42B RD +DR:V42B TD |

Tabella 3: Altri messaggi di connessione

Altri messaggi

Il modem può generare i messaggi seguenti.

Codice numerico | Messaggio di testo | Significato
+F4 | +FCERROR | Rilevato tonalità di fax o portante dati non valido; modem ritornato allo stato di comando.
ERRM=ICLID_202 | ERRM=ICLID_202 | Non è stato possibile fornire le informazioni di identificazione chiamata da parte della compagnia telefonica poiché le informazioni sono alterate.

Tabella 4: Altri messaggi generati


Supporto tecnico: Software per modem Motorola SM56 - Manuale dell'utente

Per il supporto tecnico telefonico, rivolgersi al rivenditore del computer o del modem.

In ogni caso, consultare innanzitutto la sezione Risoluzione dei problemi.


Connettori telefonici: Software per modem Motorola SM56 - Manuale dell'utente

La maggior parte dei modem è dotata di due connettori telefonici RJ-11 , con l'etichetta LINE (verde) e PHONE.

Per installare il modem, collegare un cavo telefonico dalla presa telefonica al connettore LINE. Eventualmente, collegare l'apparecchio telefonico al connettore PHONE. L'apparecchio telefonico, se collegato, funzionerà normalmente anche a computer spento.

Non è possibile utilizzare il telefono se il modem è collegato. Eventuali tentativi di utilizzare l'apparecchio telefonico mentre si è collegati potrebbero causare una disconnessione del modem.


Risoluzione dei problemi: Software per modem Motorola SM56 - Manuale dell'utente

Se si verifica un problema durante la composizione o la ricezione di una chiamata oppure durante la trasmissione di dati e il programma di comunicazione in uso non fornisce informazioni al riguardo, è possibile consultare il seguente elenco di problemi e suggerimenti.

Le applicazioni MS-DOS di Windows 98 non funzionano con il modem

Se le applicazioni per MS-DOS non funzionano:

1. Aprire il Pannello di controllo.

2. Fare doppio clic sull'icona Sistema.

3. Espandere il ramo Modem.

4. Fare doppio clic sul modem Motorola SM56.

5. Selezionare la scheda Modem. Annotare il numero della porta COM.

6. Selezionare la scheda Risorse. Annotare il numero degli IRQ in elenco.

7. Affinché il supporto MS-DOS funzioni correttamente, è necessario che il modem SM56 non si trovi sull'IRQ standard per il numero della porta COM.

8. Disattivare la casella di controllo Utilizza risorse automatiche.

9. Fare doppio clic sull'etichetta Richiesta di interrupt e modificare il numero dell'IRQ con un valore non in conflitto con altre periferiche (se non esistono IRQ disponibili, liberarne uno o modificare i livelli di IRQ di un'altra periferica, impostandola su un IRQ non standard).

Segnale di linea assente

1. Accertarsi che il cavo telefonico sia collegato in modo corretto ad entrambe le estremità.

2. Scollegare il cavo telefonico dal computer e collegarlo direttamente a un telefono con presa a muro. Verificare la presenza del segnale di linea. Se non è presente, il problema è da attribuire alla linea telefonica o al sistema. Rivolgersi al provider di servizi Internet.

Il modem non è in grado di completare la connessione a un altro modem

1. Accertarsi che il modem componga il numero corretto. Verificare di aver specificato il prefisso esatto, se richiesto.

2. Verificare che il modem remoto sia configurato correttamente per la comunicazione con il modem locale.

Il modem non risponde alle chiamate in arrivo

1. Accertarsi che il parametro di risposta automatica sia impostato su attivo, utilizzando il comando ATS0 (ATS0=1 per rispondere dopo uno squillo, ATS0=2 per rispondere dopo due squilli e così via).

2. Accertarsi che nessun'altra periferica, quale un fax o una segreteria telefonica, sia impostata per rispondere alla chiamata prima del modem.

Il modem si disconnette mentre la trasmissione è in corso

1. Accertarsi che il cavo telefonico sia collegato in modo corretto a entrambe le estremità.

2. Accertarsi che la funzione di chiamata in attesa sia disabilitata. In molte aree, per disabilitare tale funzione è necessario il comando *70 o #70. Verificare con la compagnia telefonica la sequenza corretta (se la funzione è attiva, la tonalità generata dalla chiamata in arrivo, simile a un clic, potrebbe interrompere la chiamata).

Nessun dato trasmesso o ricevuto per prolungati intervalli di tempo

1. Ripetere la chiamata (la connessione sulla linea potrebbe essere particolarmente scadente).

2. Provare a utilizzare il numero di un altro provider di servizi Internet, il server potrebbe essere occupato.

3. Contattare il proprio provider di servizi Internet e verificare che non ci siano problemi sul server o altri problemi che potrebbero causare rallentamenti nella trasmissione dei dati.

Il computer è più lento del solito

1. Chiudere tutte le applicazioni aperte e inutilizzate.

Non è possibile inserire le selezioni di tonalità durante la chiamata di applicazioni basate sulle tonalità

1. Quando si chiama un sistema remoto che richiede l'invio di selezioni di tonalità tramite i tasti dell'apparecchio telefonico, quali caselle di posta vocale o sistemi di informazioni bancarie, è possibile aumentare la durata delle tonalità inviate dal modem, in modo che il sistema remoto possa rilevarle più correttamente. Per regolare la lunghezza delle tonalità DMTF, utilizzare il comando AT+VTDn, dove n indica la durata delle tonalità.

Il modem non risponde ai comandi AT

1. Accertarsi che il software di comunicazione sia configurato per utilizzare la stessa porta COM utilizzata dal modem.

2. Ripristinare i valori predefiniti del modem, digitando AT&F; quindi inserire nuovamente le opzioni personalizzate.

Il modem risponde ai comandi, ma questi non vengono visualizzati sullo schermo

1. Accertarsi che l'opzione Local Display Echo sia attivata digitando il comando ATE1.

2. Premere Invio.

Dopo l'installazione di una nuova periferica, il modem non funziona

1. Nel desktop di Windows, selezionare Start.

2. Selezionare Guida in linea. Viene visualizzata la finestra relativa agli argomenti della Guida di Windows.

3. Selezionare la scheda Sommario.

4. Selezionare Risoluzione di conflitti hardware.

5. Verrà visualizzata una serie di procedure di risoluzione dei problemi. Applicare la procedura appropriata.

Un rumore verrà riprodotto dal sistema audio del PC (nei modem dati/fax/vivavoce)

1. Posizionare gli altoparlanti ad almeno 1 metro di distanza dal microfono.

2. Assicurarsi che gli altoparlanti siano rivolti contro il microfono.

3. Diminuire il volume dell'altoparlante.

4. Parlare tenendo il microfono a una distanza di almeno 30 cm dalla bocca. Minimizzare il rumore di fondo.

5. Se il rumore persiste, spegnere il microfono nel pannello di controllo del volume.

Il modem si connette, dopodiché vengono visualizzati dei caratteri senza significato

1. Aprire il Pannello di controllo. Fare doppio clic sull'icona Modem.

2. Selezionare il modem Motorola SM56.

3. Fare clic su Proprietà.

4. Selezionare Connessione.

5. Fare clic su Avanzate.

6. Selezionare le caselle Usa controllo di errore e Richiesto per la connessione.

Il modem non riesce a connettersi e l'opzione di controllo degli errori è selezionata

È possibile che il modem si connetta a una velocità superiore rispetto a quella appropriata per le condizioni della linea.

1. Utilizzare il comando AT%B per limitare la velocità massima di connessione del modem (vedere la sezione relativa ai comandi AT% per maggiori dettagli).

2. Ridurre la velocità, utilizzando i comandi AT, fino alla risoluzione del problema. Per aggiungere i comandi AT, vedere la sezione successiva.

Il modem non viene rilevato dal sistema

1. Riavviare il computer.

2. Se anche dopo il riavvio del sistema il modem non viene rilevato, disinstallarlo e installarlo nuovamente.


Disinstallazione del modem: Software per modem Motorola SM56 - Manuale dell'utente

Disinstallazione del software • Disinstallazione dell'hardware

Questa sezione illustra la procedura di rimozione del modem dal computer. La procedura di disinstallazione si compone di due fasi:

• disinstallazione del software;

• disinstallazione dell'hardware.

Disinstallazione del software

1. Selezionare Start, quindi Impostazioni e Pannello di controllo.

2. Aprire Installazione appplicazioni

3. Selezionare Disinstallazione del modem Motorola SM56. Selezionare Aggiungi/Rimuovi

Disinstallazione dell'hardware

1. Spegnere il computer e disconnettere l'alimentazione.

ATTENZIONE: quando si rimuove un modem interno dal computer, scollegare il cavo telefonico e i cavi di alimentazione dal computer stesso. Attendere tre o quattro minuti in modo che la scheda modem si raffreddi prima di rimuoverla.

2. Disconnettere i cavi telefonici dal connettore della scheda modem.

3. Aprire il cabinet.

4. Rimuovere la scheda di interfaccia di linea del modem.

5. Richiudere il cabinet. Collegare il computer alla presa elettrica e riavviarlo.

La procedura di disinstallazione è ora completata.


Disinstallazione e aggiornamento del modem SM56: Software per modem Motorola SM56 - Manuale dell'utente

Procedura di disinstallazione del modem SM56 • Procedura di aggiornamento software del modem SM56 • Ripristino dopo un aggiornamento non riuscito

È possibile aggiornare il software quando sono disponibili nuove funzioni. Nella maggior parte dei casi, non è necessario un nuovo hardware.

Procedura di disinstallazione SM56

1. Aprire il Pannello di controllo.

2. Selezionare Installazione applicazioni.

3. Nella finestra di dialogo, selezionare Disinstallazione modem... Motorola SM56.

4. Selezionare Aggiungi/Rimuovi.

5. Spegnere il computer.

6. Rimuovere la scheda modem SM56 dal computer.

Procedura di aggiornamento del software SM56

Per aggiornare il modem SM56 con una versione più recente, attenersi alla procedura riportata di seguito:

1. Procurarsi la versione più recente del software dal rivenditore del modem.

2. Eseguire sm56set.exe e rispondere alle richieste della procedura guidata di aggiornamento. L'utilità di aggiornamento conserva una copia di backup della versione precedente nella cartella \Windows\Motorolabak. Inoltre, vengono mantenute le impostazioni relative alla porta COM del modem, al Paese e alla lingua, in modo che tutte le applicazioni di comunicazione continuino a funzionare correttamente.

Ripristino dopo un aggiornamento non riuscito

Se, dopo un aggiornamento del modem, si verificano problemi con il nuovo driver, è possibile ripristinare l'installazione precedente del software SM56 eseguendo tutti i passaggi riportati di seguito:

1. Aprire il Pannello di controllo. Selezionare i programmi da Aggiungi/Rimuovi.

2. Se SM56 Modem si trova nell'elenco dei programmi installati, selezionarlo, quindi fare clic su Aggiungi/Rimuovi per eseguire il programma di disinstallazione.

3. Riavviare il computer.

4. Dopo il riavvio, reinstallare il modem SM56 dalla directory di backup \Windows\Motorolabak.

In questo modo, verrà reinstallato il software precedente.


V.90/V.92 e K56flex: Software per modem Motorola SM56 - Manuale dell'utente

Le tecnologie V.90/V.92 e K56flex™ consentono di collegarsi a Internet a velocità che arrivano fino al doppio di quelle dei normali modem V.34. La velocità massima in ricezione è di 56Kbps, mentre in direzione opposta le velocità di connessione arrivano fino a 48.0 Kbps. Tale condizione è particolarmente adatta per le connessioni a Internet, nelle quali la maggioranza dei dati vengono trasferiti da Internet al computer client.

Grazie alla tecnologia V.92, gli utenti possono raggiungere il più alto grado di interoperabilità con i provider di servizi Internet (ISP) poiché, per essere conformi all'iniziativa ITU V.92, la maggior parte di essi si sta convertendo allo standard V.92.

V.92 è l'ultima e più avanzata tecnologia analogica disponibile oggi. Fornisce agli utenti un'esperienza "broadband-like" di Internet. V.92 consente:

• una più rapida connessione ISP

• invio di dati a velocità superiori (fino a 48Kbps)

• modalità di attesa della connessione Internet mentre si effettua o si riceve un'altra chiamata. (Ciò richiede il supporto dell'ISP e il servizio di segnale di attesa di chiamata dalla compagnia telefonica.)

Per ulteriori informazioni, visitare i siti Web V.90 e V.92 (www.v90.com, www.v92.com); tra le molte informazioni disponibili:

• un elenco completo di provider di servizi Internet (ISP) che supporta la tecnologia V.90/V.92;

• le ultime notizie sulla tecnologia V.90/V.92;

• la documentazione tecnica sulla tecnologia V.90/V.92;

• domande frequenti sulla tecnologia V.90/V.92.

Per usare lo standard V.90/V.92, contattare il proprio provider di servizi Internet per:

• Accertarsi che supporti la tecnologia V.90/V.92.

• Ottenere il numero da comporre per la connessione con tecnologia V.90/V.92.

NOTA: non sarà sempre possibile ottenere una velocità di 56Kbps, a causa di condizioni sfavorevoli della linea.

Quando il modem si connette a un head-end non V.90/V.92:

• Se l'head-end è conforme alla tecnologia K56flex™, il modem si connette alla velocità K56flex™.

• Se l'head-end è conforme alla tecnologia X2™, il modem si connette alla velocità V.34.